All add-ons currently require PHP 7.4 or greater.

On July 4th 2024 PHP 8.2 will be the new minimum requirement for all add-ons. Expect any add-on released after that date to require 8.2 or greater. Some releases may not immediately take advantage of 8.x specific features in PHP, which means you might, be able to continue using new releases in PHP 7.4, however, if you experience an error the first thing you should do is update to PHP 8.2 then create a support ticket if the error persists.

Publisher does not support the Fluid field type. Please do not contact asking when support will be available.

If you purchased an add-on from expressionengine.com, be sure to visit boldminded.com/claim to add the license to your account here on boldminded.com.

Ticket: Conflict between Publisher and Pages module

Status Resolved
Add-on / Version Publisher 1.4.0
Severity Critical
EE Version 2.8.1

Pete Heaney

Jun 20, 2014

I have an issue where there appears to be some kind of conflict between Publisher and the Pages module.

I am only using Publisher for the draft/approval process. I’m not using any of the translation features.

The channel on which I’m experiencing problems is NOT one of the channels selected to require approvals in the Publisher settings. i.e. this channel is not checked next to “Channel entry approvals” in the Publisher settings.

When Publisher is enabled, any newly created pages are not accessible. Attempting to visit the new page results in a 404 and a PHP error:

Severity: Notice
Message: Undefined offset: 68
Filename: libraries/Core.php
Line Number: 680

All pages that were created before installing Publisher are not affected by this problem.

If I attempt to visit the new page by using the template group/name and url_title, the page loads fine, which is why I believe the issue is related to the Pages module.

It’s as if Publisher is somehow causing the Pages module to fail to establish which template should be used to display the page.

Hopefully this is somewhat clear. It’s difficult to pinpoint exactly what the issue actually is. If you need any more info just shout.

Thanks,
Pete

#1

BoldMinded (Brian)

It’s clear, thanks for the report. I’ll try to replicate it this weekend and see if I can find the issue.

#2

BoldMinded (Brian)

Pete, I’m unable to replicate this. When you create a new page, is it a child of another page or a top level page? Can you by chance create a quick screen capture video so I see what you are seeing?

#3

Pete Heaney

Thanks for looking into it over the weekend.

I’ve tested it with both top level pages and a page that is a child of another page; it makes no difference.

I’ve created a quick screencast demonstrating the process of:

1) creating a new entry 2) attempting to load the page (results in a 404 + PHP error) 3) disabling the Publisher addon 4) attempting to load the page again (this time, successfully)

Let me know if there’s anything else I can do.

Thanks, Pete

#4

Pete Heaney

Sorry, forgot to post the link to the screencast - http://www.screenr.com/5RKN

#5

BoldMinded (Brian)

Pete, I haven’t forgotten about this, its been a busy week. I’ll try to take a look at this again in the next 2-3 days.

#6

BoldMinded (Brian)

Out of curiosity, have you tried replicating this in a clean EE environment with ONLY Pages and Publisher installed, nothing else?

#7

BoldMinded (Brian)

Pete, I’m going to need FTP access to debug this.

#8

Pete Heaney

I’ve tested with a clean EE install with only Pages and Publisher installed - I cannot replicate the issue in that environment.

I’ve added FTP details to this ticket.

#9

BoldMinded (Brian)

In that case, you’ll need to either start adding add-ons until the issue starts again in the new environment, or removing add-ons in the old environment until it stops working before I look into this. If its an add-on conflict, as the new environment suggests, then I need to know which add-on it is before I spend time debugging.

#10

Pete Heaney

Thought you might say that. Ok, leave it it with me. I’ll start from a clean install and see if the problem arises again.

Thanks for you help.

Pete

#11

BoldMinded (Brian)

I’m more than happy to take a look once you determine which add-on is the issue, I just can’t spend time rummaging through a full build to find the cause.

Login to reply