All add-ons currently require PHP 7.4 or greater.

On July 4th 2024 PHP 8.2 will be the new minimum requirement for all add-ons. Expect any add-on released after that date to require 8.2 or greater. Some releases may not immediately take advantage of 8.x specific features in PHP, which means you might, be able to continue using new releases in PHP 7.4, however, if you experience an error the first thing you should do is update to PHP 8.2 then create a support ticket if the error persists.

Publisher does not support the Fluid field type. Please do not contact asking when support will be available.

If you purchased an add-on from expressionengine.com, be sure to visit boldminded.com/claim to add the license to your account here on boldminded.com.

Ticket: Youtube Iframe embid in Wyvern issues ...

Status Resolved
Add-on / Version
Severity Trivial
EE Version

Jan Paul Voorberg

May 24, 2013

I already read this sulution here: http://devot-ee.com/add-ons/support/wyvern/viewthread/3072

But when I install that plugin and then press the button in Wyvern I get a transparent white screen and no popup dialog.

Also, even though I removed the plugin now, the youtube button option is still available as a toolbar button. Should I remove the button myself in the database of is there a cleaner way to do this? I already removed the “‘YouTube’ => ‘no’,” from the config file.

Anyway, the solution described in the link is not working for me, tried to delete cash but still no go.

Please help?

P.S. I can add youtube embed code to the source of the page but when I save the entry again after the embed code suddenly disappears.

#1

BoldMinded (Brian)

Hi Jan Paul, did you look at your javascript console to see if there were any errors? The white screen with no popup indicates that some javascript failed somewhere.

If you set the toolbar option to no then it shouldn’t show up anymore in your editor. If its still listed as an option then that might be a minor bug b/c its saved in the database row as “no”

Also, make sure you’re using the latest version of Wyvern, it includes a small fix to prevent some HTML from being stripped from the source.

#2

BoldMinded (Brian)

Jan Paul, any updates on this?

#3

Jan Paul Voorberg

Didn’t yet take the time to look into this, please keep it open, will look at it when I have some time.

#4

BoldMinded (Brian)

Jan, this just crossed my mind, but a lot of those plugins don’t work with CKEditor 4, or you need to upgrade to the lastest version of the plugin. I had this issue with a different plugin the other day when testing something. I went to ckeditor.com and found the latest plugin files and it started working.

#5

BoldMinded (Brian)

If you’re not using Wyvern Video, but some other embed plugin, then technically it isn’t a Wyvern related issue, its a CKEditor issue, thus possibly needing the latest version of the plugin.

#6

Jan Paul Voorberg

I’m uploading the latest version of ckeditor and the youtube plugin now, I’ll report back how it goes…

Can you still answer this question for me?:

“Also, even though I removed the plugin now, the youtube button option is still available as a toolbar button. Should I remove the button myself in the database of is there a cleaner way to do this? I already removed the “‘YouTube’ => ‘no’,” from the config file.”

i tried to delete it from the database but when i did this I got lot’s of error message on the page where I can select and order the toolbar buttons. Can you please tell me How I can remove this without errors? When I install the youtube plugin it shows 2 youtube fields now on the page where I can select the buttons I want because of that entry in the database I assume.

#7

Jan Paul Voorberg

Ok I just tried the youtube button again after reinstalling this plugin: http://sourceforge.net/projects/ckeditoryoutube/.

This is the js error that I’m getting:

CKEDITOR.tools.extend.append ckeditor.js:72 CKEDITOR.tools.extend.appendTo ckeditor.js:50 CKEDITOR.dialog ckeditor.js:482 CKEDITOR.tools.extend.openDialog ckeditor.js:523 (anonymous function) ckeditor.js:523 n ckeditor.js:202 r ckeditor.js:202 p ckeditor.js:202 (anonymous function)

Any idea what the cause is and how to fix it?

I also tried this plugin: http://ckeditor.com/addon/youtube. But with that one the youtube button never shows up. I tried putting this particiulat plugin in the ckeditor plugin directory and in the wyvern plugin dir. Both not giving me ayoutube button.

#8

Jan Paul Voorberg

P.s. i get that error when i press the button/when i get the white screen

#9

BoldMinded (Brian)

Jan, I can’t assist with the 3rd party plugins like that. Wyvern Video loads YouTube videos though.

I’m going to email you a new build, I think it’ll help with the toolbar issue.

#10

Jan Paul Voorberg

Ok I understand, thanks for the files.I

Any feedback on the button not being removable from the database though? I mean when I do I get lots of error messages in the wyvern page where I edit the buttons.

#11

BoldMinded (Brian)

Did you try the new version of Wyvern I sent? Also, please post said errors if they are still visible after updating to the latest version.

#12

Jan Paul Voorberg

This is the error i get when i remove “s:7:”Youtube”;s:2:”no”; “from the wyvern_toolbars table in the row “Default”:

A PHP Error was encountered Severity: Notice

Message: unserialize() [function.unserialize]: Unexpected end of serialized data

Filename: wyvern/helper.wyvern.php

Line Number: 513

#13

Jan Paul Voorberg

This is the entrire contents of that table row:

a:32:{s:4:”Bold”;s:3:”yes”;s:6:”Italic”;s:3:”yes”;s:11:”Superscript”;s:3:”yes”;s:9:”Subscript”;s:3:”yes”;s:12:”NumberedList”;s:3:”yes”;s:12:”BulletedList”;s:3:”yes”;s:6:”Indent”;s:3:”yes”;s:7:”Outdent”;s:3:”yes”;s:4:”Link”;s:3:”yes”;s:6:”Unlink”;s:3:”yes”;s:6:”Anchor”;s:3:”yes”;s:5:”Image”;s:3:”yes”;s:13:”ChannelImages”;s:3:”yes”;s:11:”FileManager”;s:3:”yes”;s:6:”Format”;s:3:”yes”;s:7:”NEW_ROW”;s:2:”no”;s:5:”Flash”;s:2:”no”;s:5:”Table”;s:2:”no”;s:14:”HorizontalRule”;s:2:”no”;s:11:”SpecialChar”;s:2:”no”;s:4:”Undo”;s:2:”no”;s:4:”Redo”;s:2:”no”;s:9:”PasteText”;s:2:”no”;s:13:”PasteFromWord”;s:2:”no”;s:8:”Maximize”;s:2:”no”;s:6:”Source”;s:2:”no”;s:6:”Styles”;s:2:”no”;s:8:”Ckeditor”;s:2:”no”;s:10:”Blockquote”;s:2:”no”;s:9:”Templates”;s:2:”no”;s:15:”Syntaxhighlight”;s:2:”no”;s:7:”Youtube”;s:2:”no”;}

#14

Jan Paul Voorberg

I just installed the 1.6 version you send me and I’m getting these errors now when i start a new entry A PHP Error was encountered Severity: Warning Message: array_merge() [function.array-merge]: Argument #2 is not an array Filename: wyvern/helper.wyvern.php Line Number: 270 A PHP Error was encountered Severity: Warning Message: implode() [function.implode]: Invalid arguments passed Filename: wyvern/helper.wyvern.php Line Number: 270

and

A PHP Error was encountered Severity: Warning

Message: Invalid argument supplied for foreach()

Filename: wyvern/helper.wyvern.php

Line Number: 539

when i go to the modulepage…

#15

Jan Paul Voorberg

Also, can I ask you a question about adding a youtube frame embed to the source code? I read here that someone else whas able to do this: http://devot-ee.com/add-ons/support/wyvern/viewthread/3072

But when I add youtube embeds to the source code they are automatically removed and replaced by  . The only way for me to add youtube embeds currently is to save the entry when wyvern is in source code mode. This way the youtube embed is saved and shows up in the entry on the website… BUT next time I lead the entry again in the admin to make an edit for example the youtube video is automatically removed on load.

Is this normal behavior or is this also an abnormality?

#16

Jan Paul Voorberg

P.S. I’m using Chrome, if that matters

#17

BoldMinded (Brian)

Did you try Wyvern Video? I emailed that as well.

#18

Jan Paul Voorberg

No, i didn’t try that because I don’t want to pay $40 just to be able to embed a youtube video in my article which should be possible by default in my opinion. I mean at least by editing the source code directly. I don’t need advanced video functionality and paying 40 dollar just to be able to embed a youtube video feels kind of over the top to me.

Maybe I will just try a clean install of wyvern because this is not working for me..

#19

BoldMinded (Brian)

If Wyvern Video works for you, I’ll gift you a copy on Devot:ee, on the house.

#20

Jan Paul Voorberg

Ok, Somehow I fixed this, I suspect by installing 1.5.9. (I had a slightly older version installed). Did some other things also so not 100% sure if that’s why things are fixed now.

One last request though, I asked this 2 times before when you read back, can you please let me know how I can remove the youtube button from the database? It’s just sitting there even though the youtube plugin has already been removed, but when I remove it (“s:7:“Youtube”;s:2:“no”;) from wyvern_toolbars in the database I get loads of errors at the wyvern add on screen.

#21

Jan Paul Voorberg

Ah, I figured it out, had a look at how the serialized array format works, and I missed the adjusting the array count. Now fixed :D

All my issues are fixed now, the other ticked also. Thanks for your help.

#22

BoldMinded (Brian)

Sorry I didn’t give direction on that, you said you were going to re-install so I figured it would fix itself, but forgot that uninstalling does not delete toolbar configurations :(

Glad you figured it out though!

Shoot me an email at support at boldminded dot com and mention this thread if you want me to gift you a copy of Wyvern Video for your troubles. I’ll just need your screen name or username to gift it.

Login to reply