Publisher does not support the Fluid field type. Please do not contact asking when support will be available.

If you purchased an add-on from, be sure to visit to add the license to your account here on

Ticket: DG job looks like it’s running but no entries are added

Status Resolved
Add-on / Version DataGrab 5.0.2
EE Version 7.2.12

John Faulds

May 16, 2023

This video will better illustrate what’s happening than me trying to describe it in words:

This is a job that was working previously when I first tested DG 5. I’m doing it again because I’m redoing all the imports for channels relating to orders on this site again.

When I edit the settings for the job, everything looks fine. I can see data matching up to fields in the settings.

And as you can see in the video, after a moment it says how many items are in the queue, and the queue number goes down, but the progress bar stays at 0% and no entries are added.

The XML file being used is

The wallpaper and fabric channels are exactly the same except for a different category group. The wallpaper and fabric DG jobs are set up exactly the same too. I’ve already run the fabric DG job and it worked fine.

BTW, at the end of the video, where the job has been completed and you can see in the network panel that the page is constantly making GET requests to ACT URLs, that happens when jobs complete successfully. You have to refresh the page to stop it.


John Faulds

I decided to press on and ran a couple of other imports successfully. And then hit the same problem with a different channel with a completely different field group. Followed that up with another import that worked successfully.

All of these imports were working previously and in all of the cases, I just ran the existing jobs. For the second one that failed, I tried deleting and recreating the job but still got the same result the second time.


BoldMinded (Brian)

Did you check the log file notes in the docs for any indication of what could be happening?


John Faulds

I’ve got a problem with logging no longer working. I’m pretty sure it was working when I was on DG 4.x. It used to write to the default DataGrab-import.log without any config changes.

In my PHP error logs I’ve got:

Xdebug: [Step Debug] Could not connect to debugging client. Tried: ::1:9003 (from HTTP_X_FORWARDED_FOR HTTP header), localhost:9003 (fallback through xdebug.client_host/xdebug.client_port) :-(

which appears to be related to the hosting environment I’m using – – but I haven’t been able to prevent those errors from occurring. :(


John Faulds

Scratch that, looking at the wrong log file. :/

This is the end of the log file for the most recent attempt:

03:40:28 05/17/2023 Begin Importing [Gilty Wallpaper - Ncw4023] 03:40:28 05/17/2023 [Gilty Wallpaper - Ncw4023] is a new entry. 03:40:28 05/17/2023 RUNNING 03:40:28 05/17/2023 Begin Importing [Swan Lake Wallpaper - Ncw4020] 03:40:28 05/17/2023 [Swan Lake Wallpaper - Ncw4020] is a new entry. 03:40:28 05/17/2023 RUNNING 03:40:31 05/17/2023 WAITING 03:40:31 05/17/2023 WORKER STOPPED: success 03:40:31 05/17/2023 Queues are empty. Aborting. #7 03:40:31 05/17/2023 COMPLETED

John Faulds

Wasn’t looking closely enough, resolved now, sorry for wasting your time again.

Login to reply