All add-ons currently require PHP 7.4 or greater.

On July 4th 2024 PHP 8.2 will be the new minimum requirement for all add-ons. Expect any add-on released after that date to require 8.2 or greater. Some releases may not immediately take advantage of 8.x specific features in PHP, which means you might, be able to continue using new releases in PHP 7.4, however, if you experience an error the first thing you should do is update to PHP 8.2 then create a support ticket if the error persists.

Publisher does not support the Fluid field type. Please do not contact asking when support will be available.

If you purchased an add-on from expressionengine.com, be sure to visit boldminded.com/claim to add the license to your account here on boldminded.com.

Ticket: Datagrab not able to locate import file

Status Resolved
Add-on / Version DataGrab 4.2.2
Severity
EE Version 7.2.15 Pro

mediasuite

May 12, 2023

When trying to configure a new import, after inputting the url to the .csv file I want to import, I receive the following on-screen error.
It is very weird because when I enter the same URL in my browser’s address bar, the file does get located as expected.
Very strange behaviour and I’m not sure what else I can try.

We’ve just recently upgraded from EE6 to EE7 Pro and with that we’ve had to change the php version on the website to 8.0.
Can this have an impact?

Hope to hear back from you soon!

#1

BoldMinded (Brian)

Hello. The error is accurate… for some reason it can’t open the file. This is likely an issue with the server configuration, not the add-on itself. Do you have simple http auth or something in front of the site that would be preventing access?

#2

BoldMinded (Brian)

Are you viewing the site at http and the file url is at https?

#3

mediasuite

Hi, I am viewing both with https so I believe that shouldn’t be an issue.

We are using the Structure add-on which is now included in EE7. Can that possibly have anything to do with this? I tried accessing the URL directly from my webbrowser and that seems to be working just fine. Because this worked, I assumed the Structure add-on was not causing the issue but maybe I’m wrong.

#4

BoldMinded (Brian)

Structure shouldn’t have anything to do with it. Are you sure it’s properly formatted CSV? There aren’t any errant commas or quotes messing up the format or DGs ability to read it?

#5

mediasuite

Hi, Thanks for your help guiding me to the solution. It appears that something was indeed not correct in my csv file.

Have a nice day.

#6

mediasuite

Hi, I just bumped into something else worth adding to this thread. It seems that this error is somehow related to the PHP-FPM setting. I was forced to disable this but after doing so, I see the same error from my initial comment. Is PHP-FPM required for this add-on to work?

#7

BoldMinded (Brian)

No it doesn’t require FPM, should work with mod-apache just fine too.

Login to reply