All add-ons currently require PHP 7.4 or greater.

On July 4th 2024 PHP 8.2 will be the new minimum requirement for all add-ons. Expect any add-on released after that date to require 8.2 or greater. Some releases may not immediately take advantage of 8.x specific features in PHP, which means you might, be able to continue using new releases in PHP 7.4, however, if you experience an error the first thing you should do is update to PHP 8.2 then create a support ticket if the error persists.

Publisher does not support the Fluid field type. Please do not contact asking when support will be available.

If you purchased an add-on from expressionengine.com, be sure to visit boldminded.com/claim to add the license to your account here on boldminded.com.

Ticket: after enabling Diff on the CP, viewing Draft will return php errors

Status Resolved
Add-on / Version Publisher Lite 3.9.1
Severity
EE Version 7.2.11

Dan Munday

Mar 17, 2023

after enabling Diff on the CP, viewing Draft will return php errors.

https://www.dropbox.com/s/2zmeujj00dqmwe7/diff_cp_error.mov?dl=0

#1

BoldMinded (Brian)

My attempt to use php-scope to prevent package collisions with other add-ons is causing problems within my own add-ons :(

Not sure when I’ll have a chance to dig into this one… could be a few days or maybe a couple of weeks.

#2

BoldMinded (Brian)

Comment has been marked private.

#3

BoldMinded (Brian)

I’m going to close this ticket b/c a new build which should fix the issue was sent in Slack. If you’re still having trouble just re-open this ticket.

Login to reply