All add-ons currently require PHP 7.4 or greater.

On July 4th 2024 PHP 8.2 will be the new minimum requirement for all add-ons. Expect any add-on released after that date to require 8.2 or greater. Some releases may not immediately take advantage of 8.x specific features in PHP, which means you might, be able to continue using new releases in PHP 7.4, however, if you experience an error the first thing you should do is update to PHP 8.2 then create a support ticket if the error persists.

Publisher does not support the Fluid field type. Please do not contact asking when support will be available.

If you purchased an add-on from expressionengine.com, be sure to visit boldminded.com/claim to add the license to your account here on boldminded.com.

Ticket: If DeepL does not respond in timely fashion API throws exception fault (again)

Status Resolved
Add-on / Version Publisher 3.9.1dev
Severity
EE Version 6.4.5

Gavin @ JCOGS

Feb 14, 2023

This has happened before, and you indicated then that improved error handling was being implemented.
This triggered simply by trying to save a page - no translation going on - just saving an entry in base language.
DeepL account being used has character credits so not due to capacity constraint.
Clearly Publisher is polling DeepL for some reason and the API didn’t respond.
An exception error when this happens is not a good look.
After about 2 mins resubmitted same page save and it went through OK.

#1

BoldMinded (Brian)

Closing, consolidated into https://boldminded.com/support/ticket/2591

Login to reply