All add-ons currently require PHP 7.4 or greater.

On July 4th 2024 PHP 8.2 will be the new minimum requirement for all add-ons. Expect any add-on released after that date to require 8.2 or greater. Some releases may not immediately take advantage of 8.x specific features in PHP, which means you might, be able to continue using new releases in PHP 7.4, however, if you experience an error the first thing you should do is update to PHP 8.2 then create a support ticket if the error persists.

Publisher does not support the Fluid field type. Please do not contact asking when support will be available.

If you purchased an add-on from expressionengine.com, be sure to visit boldminded.com/claim to add the license to your account here on boldminded.com.

Ticket: Error when accessing settings

Status Resolved
Add-on / Version DataGrab 4.1.0
Severity
EE Version 7.2.0

Cameron Ross

Nov 17, 2022

Hi

I get this error when accessing datagrab settings

syntax error, unexpected ‘int’ (T_STRING), expecting function (T_FUNCTION) or const (T_CONST)
user/addons/datagrab/Model/ImportStatus.php:7

Stack Trace: Please include when reporting this error

We are om the following php veriosn

PHP Version 7.3.33-4+0~20220627.98+debian10~1.gbp40b3e4

Thanks

#1

BoldMinded (Brian)

I can send a new build or you can just remove “int” from each of these lines in the ImportStatus file so it looks like this:

private $added = 0;
    private $deleted = 0;
    private $error = 0;
    private $iterator = 0;
    private $updated = 0;

FYI, I’ll probably be bumping min PHP version to 7.4 early next year. If you’re on 7.3 now upgrading to 7.4 should be no problem. Consider going all the way to 8.1 if you can.

#2

Cameron Ross

Thanks for the quick response

I upgraded to 7.4 and I will upgrade to 8.1 soon

all sorted

Login to reply