All add-ons currently require PHP 7.4 or greater.

On July 4th 2024 PHP 8.2 will be the new minimum requirement for all add-ons. Expect any add-on released after that date to require 8.2 or greater. Some releases may not immediately take advantage of 8.x specific features in PHP, which means you might, be able to continue using new releases in PHP 7.4, however, if you experience an error the first thing you should do is update to PHP 8.2 then create a support ticket if the error persists.

Publisher does not support the Fluid field type. Please do not contact asking when support will be available.

If you purchased an add-on from expressionengine.com, be sure to visit boldminded.com/claim to add the license to your account here on boldminded.com.

Ticket: Free trail of publisher with fresh install of EE

Status Resolved
Add-on / Version Publisher 3.8.1
Severity
EE Version 7.1.6

Richie

Oct 21, 2022

Hi,

I am completely new to EE, we’re looking for a new CMS that will support multiple languages and I came across Publisher as an addon - however as soon as I have enabled the addon from the backend the following error is displayed.

Maybe I am missing something extremely obvious. I’ve read and followed the install instructions and I have also done another install on a different domain with different PHP and mysql versions and I’m getting the same problem.

I am currently using both the free version of EE and the trial of Publisher. I want to make sure it will work before committing to purchasing the addon.

Thanks in advance.

Richie

—————————————-

Error Caught
Call to a member function getId() on null

user/addons/publisher/Service/Handler/FieldHandler.php:262
Stack Trace: Please include when reporting this error

    #0 user/addons/publisher/upd.publisher.php(115): BoldMinded\Publisher\Service\Handler\FieldHandler->call()
    #1 ee/legacy/libraries/addons/Addons_installer.php(72): Publisher_upd->install()
    #2 ee/legacy/libraries/addons/Addons_installer.php(327): Addons_installer->install_module()
    #3 ee/legacy/libraries/addons/Addons_installer.php(37): Addons_installer->_update_addon()
    #4 ee/ExpressionEngine/Controller/Addons/Addons.php(1367): Addons_installer->install()
    #5 ee/ExpressionEngine/Controller/Addons/Addons.php(549): ExpressionEngine\Controller\Addons\Addons->installModule()
    #6 [internal function]: ExpressionEngine\Controller\Addons\Addons->install()
    #7 ee/ExpressionEngine/Core/Core.php(268): call_user_func_array()
    #8 ee/ExpressionEngine/Core/Core.php(124): ExpressionEngine\Core\Core->runController()
    #9 ee/ExpressionEngine/Boot/boot.php(184): ExpressionEngine\Core\Core->run()
    #10 dvg.php(139): require_once('...')
    #10 dvg.php(139): require_once('...')

 

#1

BoldMinded (Brian)

Hi Richie. Welcome to ExpressionEngine 😊 I usually don’t support the free trials but since you have a clear error message I’ll take a look. What version of PHP do you have?

#2

BoldMinded (Brian)

Actually this looks like a different issue… a slight regression from some new code. The next comment will contain a link to a new build.

#3

BoldMinded (Brian)

Comment has been marked private.

#4

BoldMinded (Brian)

You might also have to run all these queries on your database at the same time to force remove Publisher b/c you might be stuck in a half installed state.

delete from exp_extensions where class = 'Publisher_ext';
delete from exp_modules where module_name = 'Publisher';

SELECT * FROM (
  SELECT CONCAT('DROP TABLE ', GROUP_CONCAT(table_name) , ';')
  FROM INFORMATION_SCHEMA.TABLES
  WHERE table_name LIKE 'exp_publisher_%'
) a INTO @mystmt;

PREPARE mystatement FROM @mystmt;
EXECUTE mystatement;
#5

BoldMinded (Brian)

So to be clear, copy/paste those queries into SequelAce, phpMyAdmin or a similar tool and execute them all at the same time. Drop in the new build files and try to re-install again.

Sorry this happened to you :(

#6

Richie

Good morning Brian,

Thanks for the update, I’ll let you know once I’ve had the chance to make the changes.

Regards,

Richie 😉

Login to reply