Publisher is EE6 compatible, but it does not support the Fluid field. Please do not contact asking when support will be available.

If you purchased an add-on from expressionengine.com, be sure to visit boldminded.com/claim to add the license to your account here on boldminded.com.

Ticket: If DeepL does not respond in timely fashion API throws exception fault

Status Resolved
Add-on / Version Publisher 3.8.0
Severity
EE Version 6.3.5

Gavin @ JCOGS

Oct 18, 2022

More an FYI than anything.
Just in case you were not aware.
Has happened a few times now - doing something that interacts with DeepL API (e.g. opening add-on settings pages is enough) and EE throws an exception.
Looking at error it was unclear what cause was but suggested that DeepL was not responding.  I’ve not had presence of mind to screen grab it at the time, but refreshing page has fixed it - which suggests that possibly an unavailable DeepL service was the cause.

Not dug into the code, but suspect that you are not trapping for exceptions when calling DeepL API functions - am doing so for WebAPI version in Auto-Translate so not seen anything similar. But might be worth thinking about putting in a few

try

calls to reduce scope for such in future.

Looks like my work on the site that is using Publisher / deepl is winding down (at last) so may not see similar again for a while - but if I do I’ll try and remember to grab the error at the time and post.

#1

Gavin @ JCOGS

Oct 18, 2022

Looks like something here regressed.
Got this while saving a channel entry with a free API key that was used up.
No translation activity going on - so presumably this was just Publisher polling for sake of it.
https://ln5.sync.com/dl/540a54dc0/wevs375p-q2nmrf4a-yea2y5dd-3k76ktse

Probably another exception that should be trapped and avoided - since there was no explicit attempt to use translation feature it might be seen as unhelpful workflow etc.

#2

BoldMinded (Brian)

Oct 20, 2022

The next release will have improved error handling.

Login to reply