Publisher is EE6 compatible, but it does not support the Fluid field. Please do not contact asking when support will be available.

If you purchased an add-on from expressionengine.com, be sure to visit boldminded.com/claim to add the license to your account here on boldminded.com.

Ticket: Error trying to create a new import

Status Resolved
Add-on / Version DataGrab 4.0.5
Severity
EE Version 7.1.6

andrew loveday

Oct 12, 2022

I have a clients site on a development domain and have upgraded to EE v7 and php 8.1

When trying to ‘create new import’ I get the following error….

Call to a member function getErrors() on null
user/addons/datagrab/mcp.datagrab.php:243

Stack Trace: Please include when reporting this error
#0 [internal function]: Datagrab_mcp->check_settings()
#1 ee/ExpressionEngine/Controller/Addons/Addons.php(1513): call_user_func_array(Array, Array)
#2 ee/ExpressionEngine/Controller/Addons/Addons.php(801): ExpressionEngine\Controller\Addons\Addons->getModuleSettings(‘datagrab’, ‘check_settings’, Array)
#3 [internal function]: ExpressionEngine\Controller\Addons\Addons->settings(‘datagrab’, ‘check_settings’)
#4 ee/ExpressionEngine/Core/Core.php(268): call_user_func_array(Array, Array)
#5 ee/ExpressionEngine/Core/Core.php(124): ExpressionEngine\Core\Core->runController(Array)
#6 ee/ExpressionEngine/Boot/boot.php(184): ExpressionEngine\Core\Core->run(Object(ExpressionEngine\Core\Request))
#7 index.php(143): require_once(’...’)
#7 index.php(143): require_once(’...’)

#1

andrew loveday

Oct 12, 2022

....

I have tried switching between php versions to see if the latest php was the root cause but it was not.

I have tried this on php 7.2, php 7.4, php 8.0 and php 8.1.

#2

BoldMinded (Brian)

Oct 12, 2022

Hi, Andrew. Can you please share screenshots of the Datagrab configuration pages before you hit save thus causing the error?

#3

andrew loveday

Oct 12, 2022

Hi Brian,

The only option I have is to create a new import I don’t seem to have any links to configuration?

Could you tell me how to find that please?

Thanks

#4

andrew loveday

Oct 12, 2022

I have added a screenshot of the config page where I pu the licence key in.

Unsure if that is what you wanted but it is the only config page i can find

#5

andrew loveday

Oct 12, 2022

sorry just realised what you mean i am going to upload that config now in the edit post option

#6

BoldMinded (Brian)

Oct 12, 2022

Have you verified the CSV file format is correct? Are you able to share it with me so I can try to configure the import locally?

#7

andrew loveday

Oct 12, 2022

I have emailed it toy uo but it is 27MB so may take a little time coming through

#8

andrew loveday

Oct 12, 2022

I used a plugin to export the csv from expressionengine so I would assume (and hope) the csv is in the correct format.

#9

BoldMinded (Brian)

Oct 12, 2022

Are you 100% sure the path to your csv file is correct? I was able to use your CSV and configure an import just fine without errors.

#10

BoldMinded (Brian)

Oct 12, 2022

I tried this in php 7.4 and 8.1 and it seems to work fine for me. I’m leaning towards this being an incorrect import path for the file.

#11

andrew loveday

Oct 12, 2022

I’ve tried both

https://www.craft-ee.uk/exports/super_export_plans.csv

and

{base_url}/exports/super_export_plans.csv

#12

BoldMinded (Brian)

Oct 12, 2022

Do yo have any simple http auth logins on your site? I’ve seen DataGrab not be able to load files b/c the cURL request can’t handle the login.

Did you check the DataGrab-log.txt file in the cache directory as noted in the DataGrab docs for potential additional error messages?

#13

BoldMinded (Brian)

Oct 12, 2022

The login you provided in the ticket details doesn’t work either, so I can’t login to look at it.

#14

andrew loveday

Oct 12, 2022

I failed to set the user as admin sorry.

I have changed the role now.

I do not believe there are any simple http auth logins on the site no.

Thanks

Andrew

#15

andrew loveday

Oct 12, 2022

FYI I have moved the files now as it breeches data protection and there was a lot of sensitive information in that csv file on the server.

If you need me to add it so you can test let me know and I’ll send you the url via email.

#16

BoldMinded (Brian)

Oct 12, 2022

The CP login still doesn’t work.

#17

BoldMinded (Brian)

Oct 24, 2022

Closing this out b/c I haven’t heard any responses in a couple of weeks. If this is still an issue feel free to reopen the ticket and provide the requested information.

Login to reply