All add-ons currently require PHP 7.4 or greater.

On July 4th 2024 PHP 8.2 will be the new minimum requirement for all add-ons. Expect any add-on released after that date to require 8.2 or greater. Some releases may not immediately take advantage of 8.x specific features in PHP, which means you might, be able to continue using new releases in PHP 7.4, however, if you experience an error the first thing you should do is update to PHP 8.2 then create a support ticket if the error persists.

Publisher does not support the Fluid field type. Please do not contact asking when support will be available.

If you purchased an add-on from, be sure to visit to add the license to your account here on

Ticket: {exp:publisher:languages} tag outputting nothing

Status Resolved
Add-on / Version Publisher 3.5.3
EE Version 6.3.4


May 24, 2022

Hi Brian,

I have an issue going on with {exp:publisher:languages} tag outputing nothing and don’t know exactly how to interpret the debug output.
Don’t know if it is a bug but {exp:publisher:switcher style="links"} works (but doesn’t allow customization).

I always used

<a href="{switch_language_url}" title="{long_name}">{short_name}</a>

to ouput translation links in my other previous websites and it always worked so I switched on the debug output but there is nothing significant to exploit.

0.017916 / 17.2MB Calling Tag: {exp:publisher:languages}
0.023024 / 17.2MB -> Data Returned
0.023056 / 17.2MB - End Tag Processing -
0.024619 / 17.2MB Calling Extension Class/Method: Publisher_ext/template_post_parse

Do you see any reason why the {exp:publisher:languages} gives nothing to put me on rails?

Thanks for your help.






BoldMinded (Brian)

Hard to say without seeing your Publisher settings. Do you have phrases for all the languages?



Comment has been marked private.


BoldMinded (Brian)

You don’t have any phrase translations for the languages, this is likely the problem.



But unfortunately I have no possibility to add any translations to these automatically created phrases (as you can see on the image I just attached to the ticket).


BoldMinded (Brian)

You click the pencil icon to edit the phrase, and add the translations there, just like any other phrase.



Comment has been marked private.


BoldMinded (Brian)

Is this a new installation or an upgrade from an older version of Publisher?

I’ve seen this happen before, and you’ll need to provide FTP and CP access so I can fix the database manually.


BoldMinded (Brian)

Edit the ticket and provide the CP and FTP info in the provided fields.



This is a new installation.

I just uploaded the local MAMP installation for you on a dev server and provided the credentials to the ticket. Thanks in advance.


BoldMinded (Brian)

For some reason it didn’t create the rows in the exp_publisher_phrase_data table for those language phrases. Running these queries locally should fix it. It fixed your dev site.

BTW, you have something really weird happening on your dev site where every add-on that has a menu navigation on the left is linking to that add-on’s license page for all menu options. I had to navigate to the phrases page by typing it into the url bar. /cp/addons/settings/publisher/manage/phrases/translations/2

INSERT INTO `exp_publisher_phrase_data` (`phrase_id`, `site_id`, `lang_id`, `status`, `edit_date`, `edit_by`, `is_auto`, `phrase_value`) VALUES (1, 1, 1, 'open', 1651840827, 1, 0, 'English');
INSERT INTO `exp_publisher_phrase_data` (`phrase_id`, `site_id`, `lang_id`, `status`, `edit_date`, `edit_by`, `is_auto`, `phrase_value`) VALUES (2, 1, 1, 'open', 1651840827, 1, 0, 'French');

INSERT INTO `exp_publisher_phrase_data` (`phrase_id`, `site_id`, `lang_id`, `status`, `edit_date`, `edit_by`, `is_auto`, `phrase_value`) VALUES (1, 1, 1, 'draft', 1651840827, 1, 0, 'English');
INSERT INTO `exp_publisher_phrase_data` (`phrase_id`, `site_id`, `lang_id`, `status`, `edit_date`, `edit_by`, `is_auto`, `phrase_value`) VALUES (2, 1, 1, 'draft', 1651840827, 1, 0, 'French');

INSERT INTO `exp_publisher_phrase_data` (`phrase_id`, `site_id`, `lang_id`, `status`, `edit_date`, `edit_by`, `is_auto`, `phrase_value`) VALUES (1, 1, 2, 'open', 1651840827, 1, 0, 'English');
INSERT INTO `exp_publisher_phrase_data` (`phrase_id`, `site_id`, `lang_id`, `status`, `edit_date`, `edit_by`, `is_auto`, `phrase_value`) VALUES (2, 1, 2, 'open', 1651840827, 1, 0, 'English');

INSERT INTO `exp_publisher_phrase_data` (`phrase_id`, `site_id`, `lang_id`, `status`, `edit_date`, `edit_by`, `is_auto`, `phrase_value`) VALUES (1, 1, 2, 'draft', 1651840827, 1, 0, 'French');
INSERT INTO `exp_publisher_phrase_data` (`phrase_id`, `site_id`, `lang_id`, `status`, `edit_date`, `edit_by`, `is_auto`, `phrase_value`) VALUES (2, 1, 2, 'draft', 1651840827, 1, 0, 'French');


Thanks it works now with these adds 😊

Weird for the add-ons links, I don’t have the issue on my local installation.

Login to reply