All add-ons currently require PHP 7.4 or greater.

On July 4th 2024 PHP 8.2 will be the new minimum requirement for all add-ons. Expect any add-on released after that date to require 8.2 or greater. Some releases may not immediately take advantage of 8.x specific features in PHP, which means you might, be able to continue using new releases in PHP 7.4, however, if you experience an error the first thing you should do is update to PHP 8.2 then create a support ticket if the error persists.

Publisher does not support the Fluid field type. Please do not contact asking when support will be available.

If you purchased an add-on from expressionengine.com, be sure to visit boldminded.com/claim to add the license to your account here on boldminded.com.

Ticket: Unexpected behavior: Original language content replaced when I edit second language

Status Resolved
Add-on / Version Publisher 3.5.1
Severity
EE Version 6.2.7

Lyndy

Apr 12, 2022

I recently added Publisher to my site and went through the install process. My default language is English and I added French. I was happy to see that when I went into any of my entries that I could switch to edit French and that it defaulted to already having my English content in the French fields. Unfortunately when I edited the French fields, the English fields were replaced with the new French content. The solution was this:

1. First copy and paste my English content into Notepad since I knew it would be overwritten as soon as I edited the French content.
2. Click to edit the French and add my French content. Then hit save.
3. Switch to English and see that my English content had been replaced with French.
4. Copy and paste my English content from Notepad back into the English fields. Then hit save and it would work.

But this is a complicated process. Am I doing something wrong or is this a bug?

#1

BoldMinded (Brian)

Can you provide screenshots or video? You say fields but I don’t know what you’re referring to… all fields, grid fields etc

I don’t think there are any major bugs to cause a widespread issue like this otherwise I would have heard about it already. I’m going to send a new build in the next comment. If you made a backup of your DB before installing Publisher restore it and install the new version.

#2

BoldMinded (Brian)

It’ll also help to share screenshots of your settings pages or tell me what settings you’ve changed.

#3

BoldMinded (Brian)

Comment has been marked private.

#4

BoldMinded (Brian)

I feel like the installation process didn’t complete successfully for some reason. I just checked locally and I’m not able to replicate this.

#5

Lyndy

I took some video.

The field I’m editing in this one called “Body” is a “rich text editor” field: https://vimeo.com/699016002/dc8e94845a

In this one, I edit the title field: https://vimeo.com/699018879/6232580307

Settings: https://vimeo.com/699020052/28148a19aa

#6

BoldMinded (Brian)

Were these videos taken before or after backing up your database and installing the new build?

#7

Lyndy

I’m working on restoring the site so I can try the new build. Should have that done within an hour.

#8

Lyndy

I restored the site and installed the build you sent over and now it works great!

#9

BoldMinded (Brian)

Thats great to hear! So something probably didn’t complete successfully with the install the first time around. I’ll get this release public soon just incase anyone else encounters a similar issue.

Login to reply