Publisher is EE6 compatible, but it does not support the Fluid field. Please do not contact asking when support will be available.

If you purchased an add-on from expressionengine.com, be sure to visit boldminded.com/claim to add the license to your account here on boldminded.com.

Ticket: May I have zips of in-between versions? Trying to get an upgrade to work.

Status Client Wait
Add-on / Version Bloqs 4.30
Severity
EE Version 5.4

Paul Larson

Nov 19, 2021

Brian,

Going from 4.0.18 to 4.3 went swell. Went from 4.3 to 4.6.1 and things bombed. Tables didn’t exist that the newer version didn’t expect. Perhaps some key table was missed in the update scripts and I jumped too far? To test this theory, I’d like:

4.3.2
4.4.0
4.4.1
4.5.0
4.5.1
4.6.0

(Going straight to 4.10.2 suffers from the same problem)

xception CaughtSQLSTATE[42S02]: Base table or view not found: 1146 Table ‘bloqs461.exp_blocks_templatedefinition’ doesn’t exist:
SELECT DISTINCT t.blockdefinition_id as ‘bd_id’, t.templatedefinition_id as ‘t_id’ FROM exp_blocks_templates AS t JOIN exp_blocks_templatedefinition AS td ON td.id = t.templatedefinition_id
ee/legacy/database/drivers/mysqli/mysqli_connection.php:117
Stack Trace: Please include when reporting this error
#0 ee/legacy/database/drivers/mysqli/mysqli_driver.php(112): CI_DB_mysqli_connection->query()
#1 ee/legacy/database/DB_driver.php(270): CI_DB_mysqli_driver->_execute()
#2 ee/legacy/database/DB_driver.php(180): CI_DB_driver->simple_query()
#3 user/addons/bloqs/Database/Adapter.php(1446): CI_DB_driver->query()
#4 user/addons/bloqs/Database/Adapter.php(678): BoldMinded\Bloqs\Database\Adapter->query()

#1

BoldMinded (Brian)

Nov 19, 2021

This sounds exactly like the issue I fixed in 4.9 or 4.10 https://boldminded.com/support/ticket/2328

After I made that fix 3 people experiencing the same issue upgraded fine. Are you positive the latest files are in place and your database is in a pre upgrade state and not stuck in the middle of an upgrade?

#2

BoldMinded (Brian)

Nov 19, 2021

It was fixed in the 4.9.1 update actually.

https://boldminded.com/add-ons/bloqs/change-log

#3

BoldMinded (Brian)

Nov 19, 2021

That doesn’t appear to be the full stack trace either Bc it’s not showing me what update file the error originates from.

#4

Paul Larson

Nov 19, 2021

Do you have 4.9.1? I’ll look if I have it in my archives but if that is a potential fix to the upgrade script I’d love to try it.

#5

BoldMinded (Brian)

Nov 19, 2021

It should be an available download in your account.

#6

Paul Larson

Nov 19, 2021

Hmm…I can download 4.10.2 (which I already have).

Is there a place to download archival versions?

#7

BoldMinded (Brian)

Nov 20, 2021

The 4.10 build should fix this. If not send me the full stack trace. I don’t want to send separate zip files because that might fix it for you but it won’t fix it for other people. The fix needs to be implemented in a single version, which should be 4.9.1.

Make sure your db is back to its pre upgrade state and try that latest build again. Send the full stack trace if it doesn’t work. I need to see where the error is originating.

#8

Paul Larson

Nov 20, 2021

I think the 4.9.1 worked, and then I got it al the way to 4.10.2. Thanks!

I had two issues:

1) going from 4.0.18 to the .2, .3, I’d have those ugly errors on upgrade attempts
2) Then, editing an entry w/ bloqs would often have “blank bloqs.” They simply wouldn’t appear, save for the ‘expand all’ link
3) frontend display issues

#1 and #2 seem to be behind me.

Frontend entries are displaying, but not bombing. I think it might just be syntax. Not sure if some tags were made obsolete from 4.0.18 onward. A dev here things the issue might be that bloq start tags are in templates while the meat of the bloqs are in partials.

Hopefully it’s just template fixing at this point.

Paul

#9

Paul Larson

Nov 22, 2021

Brian:

Does it seem within the realm of possibility that bloqs template code, that worked in 4.018 - 4.3, might not work in 4.10.2 due to tag obsolescence or something?

We seem past the glaring PHP and/or missing bloq UX errors in the backend, so the 4.9.1 upgrade path must have been the ticket.

#10

BoldMinded (Brian)

Nov 22, 2021

Depends on the template code. Nothing should have changed TBH. Mind sharing what you have? Any errors on page output or in your EE Log?

Login to reply