All add-ons currently require PHP 7.4 or greater.

On July 4th 2024 PHP 8.2 will be the new minimum requirement for all add-ons. Expect any add-on released after that date to require 8.2 or greater. Some releases may not immediately take advantage of 8.x specific features in PHP, which means you might, be able to continue using new releases in PHP 7.4, however, if you experience an error the first thing you should do is update to PHP 8.2 then create a support ticket if the error persists.

Publisher does not support the Fluid field type. Please do not contact asking when support will be available.

If you purchased an add-on from expressionengine.com, be sure to visit boldminded.com/claim to add the license to your account here on boldminded.com.

Ticket: Instructions for updating

Status Resolved
Add-on / Version Bloqs 4.9
Severity
EE Version 6.1.0

Nikolina Cubra

Oct 13, 2021

Sorry if this is documented somewhere but we’ve taken over an EE6 site and all the addons are out of date.
We’ve purchased new licenses etc but could not find the correct procedure (other than backing everything up) to carry out the update procedure.
Please help.

#1

BoldMinded (Brian)

Hi, Nikolina. I’m not sure which add-ons you have, but the docs for my add-ons includes installation instructions, which are the same as upgrading. For example: https://docs.boldminded.com/bloqs/docs/installation

After the new files are on the server, you have to go into the control panel > Addons and click the upgrade button for each add-on.

Do not rename the old add-on folders to something else, for example do not rename bloqs to bloqs_backup, EE will choke and load files from the wrong folder. Replace the contents of each folder with the new files, then run the upgrades in the control panel. Always backup your database before you start a process like this.

#2

Nikolina Cubra

Hi Brian Sorry - I should have been clearer. When I tried to upgrade to 4.9.0 and the site borked. So we’ve rolled back to EE5.4.2 - the site is running bloqs 4.0.18 at present. I’ll try the bloqs upgrade again and report back

#3

BoldMinded (Brian)

Can you be more specific what “borked” means? 😊 Are you encountering an error similar to this ticket? https://boldminded.com/support/ticket/2328

#4

Nikolina Cubra

Yes. The front end wasn’t rendering the tags. The backend was showing the module as unlicensed and clicking the module threw up a stack trace. I thought I’d just messed the whole upgrade up. I’m going to try to go to 4.9.0 from 4.0.18 in EE5.4.2 now.

#5

BoldMinded (Brian)

Are you able to send me a zip file of the full size, sql dump included? Don’t need css, js, or front-end images. Since I can’t replicate this issue I need to be able to step debug it where it doesn’t work to figure out what it is.

#6

Nikolina Cubra

Exception Caught SQLSTATE[42S22]: Column not found: 1054 Unknown column ‘b.componentdefinition_id’ in ‘field list’: SELECT bd.id as bd_id, bd.group_id as bd_group_id, bd.shortname as bd_shortname, bd.name as bd_name, bd.instructions as bd_instructions, bd.deprecated as bd_deprecated, bd.deprecated_note as bd_deprecated_note, bd.preview_image as bd_preview_image, bd.preview_icon as bd_preview_icon, bd.settings as bd_settings, bd.is_component as bd_is_component, bd.is_editable as bd_is_editable, b.id as b_id, b.order as b_order, b.parent_id as b_parent_id, b.depth as b_depth, b.lft as b_lft, b.rgt as b_rgt, b.componentdefinition_id as b_componentdefinition_id, ad.id as ad_id, ad.shortname as ad_shortname, ad.name as ad_name, ad.instructions as ad_instructions, ad.order as ad_order, ad.type as ad_type, ad.settings as ad_settings, a.id as a_id FROM exp_blocks_components b LEFT JOIN exp_blocks_blockdefinition bd ON b.blockdefinition_id = bd.id LEFT JOIN exp_blocks_atomdefinition ad ON ad.blockdefinition_id = bd.id LEFT JOIN exp_blocks_atom a ON a.block_id = b.id AND a.atomdefinition_id = ad.id LEFT JOIN exp_blocks_blockgroup bg ON bd.group_id = bg.id WHERE b.componentdefinition_id = 2 ORDER BY b.order, ad.order ee/legacy/database/drivers/mysqli/mysqli_connection.php:117

Stack Trace: Please include when reporting this error

0 ee/legacy/database/drivers/mysqli/mysqli_driver.php(112): CI_DB_mysqli_connection->query()

1 ee/legacy/database/DB_driver.php(270): CI_DB_mysqli_driver->_execute()

2 ee/legacy/database/DB_driver.php(180): CI_DB_driver->simple_query()

3 user/addons/bloqs/Database/Adapter.php(1679): CI_DB_driver->query()

4 user/addons/bloqs/Database/Adapter.php(1593): BoldMinded\Bloqs\Database\Adapter->query()

5 user/addons/bloqs/Database/Adapter.php(161): BoldMinded\Bloqs\Database\Adapter->getBlocksInComponent()

6 user/addons/bloqs/ft.bloqs.php(544): BoldMinded\Bloqs\Database\Adapter->getBlocks()

7 user/addons/bloqs/ft.bloqs.php(611): Bloqs_ft->getBlocks()

8 ee/legacy/libraries/api/Api_channel_fields.php(410): Bloqs_ft->replace_tag()

9 ee/legacy/libraries/channel_entries_parser/components/Custom_field_pair.php(191): Api_channel_fields->apply()

10 ee/legacy/libraries/channel_entries_parser/Parser.php(298): EE_Channel_custom_field_pair_parser->replace()

11 ee/legacy/libraries/Channel_entries_parser.php(172): EE_Channel_data_parser->parse()

12 ee/EllisLab/Addons/channel/mod.channel.php(2846): EE_Channel_parser->parse()

13 ee/EllisLab/Addons/channel/mod.channel.php(281): Channel->parse_channel_entries()

14 ee/legacy/libraries/Template.php(1849): Channel->entries()

15 ee/legacy/libraries/Template.php(1484): EE_Template->process_tags()

16 ee/legacy/libraries/Template.php(580): EE_Template->tags()

17 ee/legacy/libraries/Template.php(236): EE_Template->parse()

18 ee/legacy/libraries/Template.php(167): EE_Template->fetch_and_parse()

19 ee/legacy/libraries/Core.php(683): EE_Template->run_template_engine()

20 ee/legacy/controllers/ee.php(63): EE_Core->generate_page()

21 [internal function]: EE->index()

22 ee/EllisLab/ExpressionEngine/Core/Core.php(268): call_user_func_array()

23 ee/EllisLab/ExpressionEngine/Core/Core.php(118): EllisLab\ExpressionEngine\Core\Core->runController()

24 ee/EllisLab/ExpressionEngine/Boot/boot.php(156): EllisLab\ExpressionEngine\Core\Core->run()

25 html/index.php(176): require_once(‘…’)

25 html/index.php(176): require_once(‘…’)

#7

Nikolina Cubra

Once the upgrade button is pressed then it churns away in the background and says successful but site is not rendering and clicking on settings in the CP gives: SQLSTATE[42S22]: Column not found: 1054 Unknown column ‘c.componentdefinition_id’ in ‘field list’: SELECT DISTINCT c.blockdefinition_id as ‘bd_id’, c.componentdefinition_id as ‘c_id’ FROM exp_blocks_components AS c JOIN exp_blocks_blockdefinition AS bd ON bd.id = c.componentdefinition_id AND bd.id != c.blockdefinition_id

I have a vitrualmin backup of the current site including the sql it is about 41MB how do you want me to send that to you?

#8

BoldMinded (Brian)

Just put it on Dropbox, a we transfer download or whatever works for you.

#9

BoldMinded (Brian)

You can post the link to the download in a comment and make it private.

#10

Nikolina Cubra

Comment has been marked private.

#11

BoldMinded (Brian)

What is a CP super admin account I can login as?

#12

BoldMinded (Brian)

I can’t find the db dump file in the zip you provided either.

#13

Nikolina Cubra

Comment has been marked private.

#14

BoldMinded (Brian)

I think I know what the issue is and will have a fix today. Apparently EE’s database smart forge class caches the existing tables for the entire request, and since you’re updating from a specific version that does not have the exp_blocks_template table yet, it is not in the cache, so when it tries to modify the column name it fails b/c it thinks the table does not exist.

(╯°□°)╯︵ ┻━┻

#15

Nikolina Cubra

Great job finding that obscure fault condition! I look forward to the fix.

#16

BoldMinded (Brian)

New build emailed. Closing this ticket b/c it’s a dupe of https://boldminded.com/support/ticket/2328

Login to reply