Publisher is EE6 compatible, but it does not support the Fluid field.

If you purchased an add-on from expressionengine.com, be sure to visit boldminded.com/claim to add the license to your account here on boldminded.com.

Ticket: Publisher breaks Wygwam field within a grid if an Ansel field is populated in the grid field also

Status Resolved
Add-on / Version Publisher 3.3.1
Severity
EE Version 5.4.2

Burgi von Mengershausen

Jun 14, 2021

Hi,

Publisher: 3.3.1
ExpressionEngine: 5.4.2
Ansel: 2.2.0
Wygwam: 5.2.0

Publisher breaks Wygwam field within a grid if an Ansel field is populated in the grid field also.

Steps to reproduce:

Create 2 languages
Create a channel with only a grid field containing an Ansel field and a Wygwam field
Create an entry in first language and enter some text in the Wygwam field in the first grid row.
Create an entry in second language and save: Wygwam works.
Add an Ansel image to first grid row in first language and save entry: Ansel and Wygwam are working
Switch to second language: Ansel and Wygwam are NOT working
Neither the image is visible nor changeable nor is the Wygwam field showing the Wygwam interface.

#1

BoldMinded (Brian)

Jun 14, 2021

I’m not sure how this is Publisher’s fault. To me that looks like a JS error is occurring and stopping Wygwam (CKEditor) from instantiating. Did you inspect your JS Console for errors? Publisher just swaps data out, it doesn’t care what is happening on the front-end in this scenario. Did you test this scenario in an EE environment without Publisher installed?

#2

Burgi von Mengershausen

Jun 15, 2021

You are probably correct, that a JS error is occurring and stopping Wygwam (CKEditor) from instantiating (please see attached screenshot of my console:

)

The problem is that this error only occurs when you switch the entry form to any other language than the default language via Publisher.

So in a default setting without Publisher there is no error at all as well with Publisher in the default language there is no error at all.

Somehow Publisher messes up Ansels JS … but only when you switch the entry form to a secondary language.

#3

BoldMinded (Brian)

Jun 15, 2021

Thats not Publisher code though. I don’t see how Publisher would cause a JS error in a separate library. What is that JS file from? Is it an Ansel file? CKEditor? Something else?

#4

Burgi von Mengershausen

Jun 19, 2021

it is an Ansel file

#5

BoldMinded (Brian)

Jun 21, 2021

If the error is coming from an Ansel file, then TJ should probably take a look at it. I have no idea what is going on or what it is attempting to do. If I need to change something in Publisher to help facilitate Ansel or stop this error I can do that, but he’ll probably need to debug it.

Login to reply