All add-ons currently require PHP 7.4 or greater.

On July 4th 2024 PHP 8.2 will be the new minimum requirement for all add-ons. Expect any add-on released after that date to require 8.2 or greater. Some releases may not immediately take advantage of 8.x specific features in PHP, which means you might, be able to continue using new releases in PHP 7.4, however, if you experience an error the first thing you should do is update to PHP 8.2 then create a support ticket if the error persists.

Publisher does not support the Fluid field type. Please do not contact asking when support will be available.

If you purchased an add-on from expressionengine.com, be sure to visit boldminded.com/claim to add the license to your account here on boldminded.com.

Ticket: Updated simple grids from 1.3.2 to 1.4.0.  text area data was deleted and will not save

Status Resolved
Add-on / Version Simple Grids & Tables 1.4.0
Severity
EE Version 6.0.6

Aasun Eble

Jun 07, 2021

Using simple grids and tables in Bloqs.

Upgraded Bloqs and simple grids this morning to latest version.

The “textarea” fields in my bloqs was deleted.  No new info will save in those fields (other fields seem ok), and the field tag is not rendered on templates..  just shows {description} (description is the name of this particular textarea field).

Help!

#1

Aasun Eble

Ok. On a follow-up.. I fixed the issue. After the update this morning, it seems that after the update, a user tried to edit an entry with the bloqs fields using the simple grid field type.. Saving caused all those textarea fields in the simple grid in that entry to be deleted. Not all simple grid textarea fields in ALL entries were deleted upon the update.. just ones edited and saved, and nothing would save in those fields.

I edited the blog and saved that textarea field, then restored the data for those edited/broken entries from a DB backup, and all is working again.

At this point, I’m not sure if there was a change in simple grids (or bloqs) that changed that field type… or, if maybe the user was trying to save while I performed the udpate (possible)… Or if something else happened. But, functionality is restored, and working again.

#2

BoldMinded (Brian)

Aasun, can you provide more clarity on what happened?

You said “The “textarea” fields in my bloqs was deleted” - Can you provide screenshots? Are these textarea fields inside of a Simple Grid/Table? Or are they standalone fields/atoms in a block?

I can’t think of anything in the recent updates to either add-on would “delete” the fields. If you can replicate this again or provide more clarity and possibly screenshots I can look into this further, but right now this is kind of vague.

#3

Aasun Eble

The text area was not deleted, the content within the text area was deleted. But, this only happened on edit and save of an entry. I thought I had fixed it yesterday. But, it’s still happening.

The data in the database (exp_blocks_atom.data) loses the textarea field data that I have set up for the blocks.

Also noticing in the exp_simple_grids_tables_settings, the installed_version is still saying 1.3.2, instead of 1.4.0.

Maybe something happened in the update that is preventing the data being saved properly when an entry is edited.

#4

BoldMinded (Brian)

If the control panel says 1.3.2 is installed, then it sounds like you haven’t clicked the Update Add-on button.

Can you please provide screenshots or videos of the issue. Screenshots of your the bloq configuration for the bloq that contains the Simple Grid field. I really need more context.

#5

Aasun Eble

The control panel says 1.4.0. The database is what says 1.3.2.

I’ll add screenshots.

#6

BoldMinded (Brian)

Comment has been marked private.

#7

Aasun Eble

Yep. That seems to work correctly. No data is deleted upon saving an entry with these fields.

#8

Aasun Eble

Using the advanced configuration options and setting the textarea field to only showing 3 rows instead of the default 6. Works great!

Is there a way to have line breaks show up on the template? Currently, new lines show in the CP field, but no character is added to the template. So, I type in ” ” in the field and that works… though, not ideal. Is there an equivalent, or way to do a php nl2br() function? on the template tag?

#9

BoldMinded (Brian)

You might be able to set the format to xhtml

'field_fmt' => 'xhtml',
#10

Aasun Eble

No effect. But thanks for the suggestion. I’ll probably just set up a custom add-on to parse the data on the template and insert the line break.

Login to reply