Publisher is EE6 compatible, but it does not support the Fluid field.

If you purchased an add-on from expressionengine.com, be sure to visit boldminded.com/claim to add the license to your account here on boldminded.com.

Ticket: Translated url title not working in channel_entries tag

Status Resolved
Add-on / Version Publisher Domain Control 2.0
Severity
EE Version 5.4

Studioweb

Mar 02, 2021

Related issue: https://boldminded.com/support/ticket/1235

Current language id: {publisher:current_language_id}<br>
Current url title: {embed:url_title}<br>

{exp:channel:entries channel="products" url_title="{embed:url_title}" dynamic="no"}
    Url title path: {url_title_path=""}

    Title: {title}

    Url title: {url_title}

    Publisher last_segment: {publisher:last_segment} 

    Page title: {page_title}

{/exp:channel:entries}

Using this code on the main domain works fine.

Using it on the second domain (configured in the publisher domain settings) doesn’t:
Current language id and Current url title are displayed but the channel entry isn’t. Structure page do work somehow.

 

 

#1

BoldMinded (Brian)

Mar 02, 2021

Can you provide more context?

What version of Publisher?

Can you share a URL where I can see this happening, and a login to the CP?

Which values isn’t translated? The url_title, last_segment, url_title_path?

You said “Current language id and Current url title are displayed but the channel entry isnt’” - So the entry doesn’t return in the entries tag at all, or the values are not translated? I’m confused.

Sorry, but I’m having trouble following what exactly the issue is, and if I can see it happening it might be more clear.

#2

Studioweb

Mar 03, 2021

Comment has been marked private.

#3

BoldMinded (Brian)

Mar 03, 2021

I think you’re going to have to provide ftp and cp access for me to look into this. Edit the ticket and use the fields provided for the credentials. Also recreate the issue in a new debug template. No css, no JS, no embeds, html or EE tags except those required to recreate the issue (sounds like it’s a single entries tag). Once you do that I can take a look.

#4

Studioweb

Mar 03, 2021

Comment has been marked private.

#5

BoldMinded (Brian)

Mar 03, 2021

Oh, this one was easy 😊 You need to use url_title=”{publisher:last_segment}” in your entries tag b/c it always needs the default language value when querying by url_title.

#6

Studioweb

Mar 03, 2021

Ah now that makes sense 😛

Login to reply