Be sure to checkout our newest add-on Speedy!

EE compatibility updates:

  • Publisher is EE5 compatible, but it does not currently support the Fluid field.

ExpressionEngine.com licenses:

  • If you purchased an add-on from expressionengine.com, be sure to visit boldminded.com/claim to add the license to your account here on boldminded.com.

Ticket: Exception Caught: SQLSTATE[42S22]: Column not found: 1054 Unknown column ‘exp_publisher_data_field_24.field_id_24’ in ‘where clause’:

Status Resolved
Add-on / Version Publisher 3.1.4
Severity
EE Version 5.3.0

Matthias Ballmann

Mar 27, 2020

I updated my ee 5.3.0. to the latest publisher 3.1.4 and suddenly get this error message on the website.
nothing else in configuration changed:

Exception Caught

SQLSTATE[42S22]: Column not found: 1054 Unknown column ‘exp_publisher_data_field_24.field_id_24’ in ‘where clause’:
SELECT `ct`.*, `t`.*, `channel_title`, `c`.`channel_name`, `c`.`channel_url`, `c`.`comment_url`, `c`.`comment_moderate`, `c`.`channel_html_formatting`, `c`.`channel_allow_img_urls`, `c`.`channel_auto_link_urls`, `c`.`comment_system_enabled`, `username`, `m`.`email`, `m`.`screen_name`, `m`.`signature`, `m`.`sig_img_filename`, `m`.`sig_img_width`, `m`.`sig_img_height`, `m`.`avatar_filename`, `m`.`avatar_width`, `m`.`avatar_height`, `m`.`photo_filename`, `m`.`photo_width`, `m`.`photo_height`, `m`.`group_id`, `m`.`member_id`, `ct`.`url_title` AS default_url_title, `ct`.`status` AS status, `t`.`title` AS title, `t`.`site_id` AS entry_site_id FROM (`exp_publisher_titles` AS t) JOIN `exp_channel_titles` AS ct ON `ct`.`entry_id` = `t`.`entry_id` JOIN `exp_channels` AS c ON `c`.`channel_id` = `t`.`channel_id` JOIN `exp_members` AS m ON `m`.`member_id` = `t`.`author_id` WHERE `t`.`entry_id` IN (107) AND `t`.`status` = ‘open’ AND `t`.`lang_id` = 1 AND ( (t.site_id=1 AND exp_publisher_data_field_24.field_id_24 LIKE “%Bücher und Kataloge%”) )

ee/legacy/database/drivers/mysqli/mysqli_connection.php:117

Stack Trace: Please include when reporting this error

#0 ee/legacy/database/drivers/mysqli/mysqli_driver.php(112): CI_DB_mysqli_connection->query(‘SELECT `ct`.*, ...’)
#1 ee/legacy/database/DB_driver.php(270): CI_DB_mysqli_driver->_execute(‘SELECT `ct`.*, ...’)
#2 ee/legacy/database/DB_driver.php(180): CI_DB_driver->simple_query(‘SELECT `ct`.*, ...’)
#3 user/addons/publisher/Service/Entry/EntryQuery.php(224): CI_DB_driver->query(‘SELECT `ct`.*, ...’)
#4 user/addons/publisher/Service/Entry/EntryResult.php(501): BoldMinded\Publisher\Service\Entry\EntryQuery->getResultArray()
#5 user/addons/publisher/legacy/libraries/hooks/Publisher_relationship_hooks.php(407): BoldMinded\Publisher\Service\Entry\EntryResult->getAllQuery(Array)
#6 user/addons/publisher/ext.publisher.php(1869): Publisher_relationship_hooks->relationships_modify_rows(Array, Object(ParseNode))
#7 ee/legacy/libraries/Extensions.php(222): Publisher_ext->relationships_modify_rows(Array, Object(ParseNode))
#8 ee/legacy/libraries/Extensions.php(117): EE_Extensions->call_class(‘Publisher_ext’, ‘relationships_m…’, Array, Array)
#9 ee/legacy/libraries/relationship_parser/Parser.php(577): EE_Extensions->call(‘relationships_m…’, Array, Object(ParseNode))
#10 ee/legacy/libraries/relationship_parser/Parser.php(207): EE_Relationship_data_parser->process_parameters(Object(ParseNode), 1418)
#11 ee/legacy/libraries/relationship_parser/Parser.php(84): EE_Relationship_data_parser->parse_node(Object(ParseNode), 1418, ‘\n\t\t\t\t

#12 ee/legacy/libraries/channel_entries_parser/components/Relationship.php(114): EE_Relationship_data_parser->

parse(1418, ‘\n\t\t\t\t

#13 ee/legacy/libraries/channel_entries_parser/Parser.php(298): EE_Channel_relationship_parser->

replace(’\n\t\t\t\t

#14 ee/legacy/libraries/Channel_entries_parser.php(172): EE_Channel_data_parser->

parse(Array, Array)
#15 ee/EllisLab/Addons/channel/mod.channel.php(2846): EE_Channel_parser->parse(Object(Channel), Array, Array)
#16 ee/EllisLab/Addons/channel/mod.channel.php(281): Channel->parse_channel_entries()
#17 ee/legacy/libraries/Template.php(1847): Channel->entries()
#18 ee/legacy/libraries/Template.php(1482): EE_Template->process_tags()
#19 ee/legacy/libraries/Template.php(578): EE_Template->tags()
#20 ee/legacy/libraries/Template.php(234): EE_Template->parse(’{!—ra:0000000…’, false, 1, false)
#21 ee/legacy/libraries/Template.php(165): EE_Template->fetch_and_parse(’‘, Array, false)
#22 ee/legacy/libraries/Core.php(661): EE_Template->run_template_engine(’‘, ‘’)
#23 ee/legacy/controllers/ee.php(63): EE_Core->generate_page()
#24 [internal function]: EE->index()
#25 ee/EllisLab/ExpressionEngine/Core/Core.php(241): call_user_func_array(Array, Array)
#26 ee/EllisLab/ExpressionEngine/Core/Core.php(110): EllisLab\ExpressionEngine\Core\Core->runController(Array)
#27 ee/EllisLab/ExpressionEngine/Boot/boot.php(151): EllisLab\ExpressionEngine\Core\Core->run(Object(EllisLab\ExpressionEngine\Core\Request))
#28 index.php(172): require_once(’...’)
#28 index.php(172): require_once(’...’)

#1

BoldMinded (Brian)

Mar 27, 2020

What does the channel:entries tag look like that is throwing this error? Specifically the opening tag with the parameters? I want to know what kind of query it’s trying to do.

#2

BoldMinded (Brian)

Mar 27, 2020

Actually it looks like it’s happening in a relationship tag pair. Please share the full channel:entries tag with _just_ the EE tags, remove all the extra html.

#3

BoldMinded (Brian)

Mar 27, 2020

Also I assume you checked the database and there is a table called exp_publisher_data_field_24 that has a column called field_id_24?

#4

Matthias Ballmann

Mar 27, 2020

Comment has been marked private.

#5

BoldMinded (Brian)

Mar 27, 2020

Matthias, it looked like you reported the exact same issue back in December of last year. https://boldminded.com/support/ticket/2027

I still have the test template setup in my environment and it still works fine for me. Was this issue fixed and it’s started happening again, or was it never fixed to begin with?

#6

Matthias Ballmann

Mar 27, 2020

and yes: the exp_publisher_data_field_24 has 30 entries and a column named field_id_24.

#7

Matthias Ballmann

Mar 27, 2020

yes, I reported this some time ago.
and the problem was never fixed because… Due to a very urgent need for action on the part of the client, we made the mistake of installing the Publisher Update without a backup, and then spent two days repairing the website. Since I was glad that the website was up and running again and we were very busy before Christmas anyway, I forgot to continue testing.

Now we want to repeat the whole thing, but luckily we not only have updates but, unlike in December, we could also exclude that this error was caused by the Structure plugin, which we had updated at the same time.

This time, only Publisher has been updated to see if the error occurs again.

#8

BoldMinded (Brian)

Mar 27, 2020

Can you update the ticket with access to a dev or staging server that the error is happening on. Also provide the URL to where I can go on the front-end to trigger the error, and share which entry_id is expected to be found by this search result. If you can create a bare bones template with only the channel:entries tag necessary to cause the error it’ll help me debug it easier by removing all the other noise that other EE template tags cause.

#9

BoldMinded (Brian)

Mar 27, 2020

FTP and CP access please (if I wasn’t clear in the previous comment)

#10

Matthias Ballmann

Mar 27, 2020

it’s a local install at the moment, but I will set up a staging server for you.

#11

Matthias Ballmann

Mar 27, 2020

Comment has been marked private.

#12

BoldMinded (Brian)

Mar 27, 2020

Comment has been marked private.

#13

Matthias Ballmann

Mar 27, 2020

Comment has been marked private.

#14

Matthias Ballmann

Mar 31, 2020

Comment has been marked private.

#15

BoldMinded (Brian)

Mar 31, 2020

Matthias, I created a new template to test with b/c the shop template has too much noise in it. Please edit the shop/test template so it causes the error. Notice how I stripped everything out… please take the same approach, only add to the template what is necessary to cause the error, and remove everything else from the template that is not required to cause the error. Once the shop/test template throws the error I will continue looking into this.

#16

Matthias Ballmann

Apr 05, 2020

hi brian, it took me some time to try all the different combinations because I don’t want you to work through some very complex code unnecessarily.
I copied your test template and named it test2.html.

The code is now very reduced and the error source is relatively well isolated - the error seems to be in the conditional that controls how artist names are displayed when more than one artist is doing an exhibition.

But there’s one odd thing: The error only occurs if the {layout:set} that generates the page title is also present. If this is missing (right at the beginning of the code, no error occurs. But since this include exists on every page and the error only occurs on these shop pages, there must be a connection to the conditional.

#17

BoldMinded (Brian)

Apr 07, 2020

It’s not the layout:set tag that is the problem, it’s the structure:nav_advanced tag inside of it.

#18

Matthias Ballmann

Apr 07, 2020

Comment has been marked private.

#19

BoldMinded (Brian)

Apr 07, 2020

After looking into it a bit more I don’t think it’s related to Structure. I’m waiting for a new build of files to upload then I’ll test again. The last build I sent you was the wrong build.

#20

BoldMinded (Brian)

Apr 07, 2020

I think this is resolved now. The search:art_des_shopartikels=“Bücher und Kataloge” tag on the entries tag was causing the child relationship tag query to mess up.

#21

Matthias Ballmann

Apr 07, 2020

So what does this mean? Do I have to change the code or is there a new version of Publisher? If there is a new version and you already have it installed, can you send it to me separately so I can test it again on the client-server? This test environment was only a temporary solution for you.

Thanks a lot for your great support

#22

BoldMinded (Brian)

Apr 07, 2020

I updated your site with the changes, and the fix will be included in the next release of Publisher. I’ll attach a new build in the next comment.

#23

Matthias Ballmann

Apr 07, 2020

so no changes in my ee code, right?

#24

BoldMinded (Brian)

Apr 07, 2020

Comment has been marked private.

#25

BoldMinded (Brian)

Apr 07, 2020

No, your template code should be fine.

#26

BoldMinded (Brian)

Apr 13, 2020

Matthias, did the build I sent fix the issue for you? If so I’m going to close this ticket.

#27

Matthias Ballmann

Apr 13, 2020

yes, after testing everything and updating to 5.3.1 everything still seems normal 😊
thanks!

#28

BoldMinded (Brian)

Apr 13, 2020

Good to hear!

Login to reply

Contact

For add-on support, please use the Support section. General inquries and pre-sale questions can be sent to support@boldminded.com.