Be sure to checkout our newest add-on Speedy!

EE compatibility updates:

  • Publisher is EE5 compatible, but it does not currently support the Fluid field.

ExpressionEngine.com licenses:

  • If you purchased an add-on from expressionengine.com, be sure to visit boldminded.com/claim to add the license to your account here on boldminded.com.

Ticket: Publisher support for Relationship field

Status Client Wait
Add-on / Version Publisher 3.1.4
Severity
EE Version 5.3.0

eHealth Ontario

Mar 25, 2020

I have created a simple test case. Relationship fields main title is translated but other fields are always in default language English.

<h1>Test Page - {publisher:current_language_code}</h1>
<p>{exp:channel:entries channel="test" url_title="test-member" dynamic="no"}<br /></p><div><pre>Test Channel Title: {title}</pre><pre>Test Channel Url Title: {url_title}</pre><pre>Test Channel Intro Text: {intro_text}</pre>
<p>		{test_member}<br /></p><pre>Team Title: {test_member:title}</pre><pre>Team Url Title: {test_member:url_title}</pre><pre>Team Job Title: {test_member:job_title}</pre>
<p>		{/test_member}<br /></p>
</div>
<p>{/exp:channel:entries}

I have Persistent Relationships enabled. I have tried disabling that option. It does not make a difference. Please assist in resolving this issue.

#1

BoldMinded (Brian)

Mar 26, 2020

I’ll try to take a look at this in the next couple of days. As far as I know there is no reason this shouldn’t be working. Is either one of the channels you’re using setup to be ignored by Publisher? Are there any ignored fields?

Is this a brand new Publisher install on an existing site or is it a Publisher upgrade? A little background to the history of the site might help.

#2

BoldMinded (Brian)

Mar 26, 2020

I just did a test locally and confirmed that this works as expected. This is a page entry that has a relationship field to my documents channel.


#3

eHealth Ontario

Mar 26, 2020

A brand new site under development. The first version installed was 3.1.1. Upgraded to 3.1.3 then to 3.1.4. Ignore options are not used. I double-checked the settings. None of the options are selected. The cache is disabled. I see an inconsistency in the database. The current version is 3.1.4. On the database, the exp_publisher_settings table has installed_version key that is set to 3.1.1. Not sure if that has any effect on the functionality.

#4

BoldMinded (Brian)

Mar 26, 2020

installed_version is the first version that was installed, it doesn’t affect functionality at all. You should check the exp_publisher_* tables for the entry_ids involved with the parent and related entry. See if the rows in the table actually contain the translated values or if both rows (default language and non-default language) contain the same text. At least then it can be narrowed down to a saving issue or front-end display issue of the content.

#5

eHealth Ontario

Mar 26, 2020

Parent Entry (Channel: Test, Entry ID: 162)
Related Entry (Channel: Team, Entry ID: 161)
Relationship field id: 16
Custom field Title in Team Channel: 13

exp_publisher_relationships has four related records
relationship_id,parent_id,child_id,field_id,grid_col_id,grid_field_id,grid_row_id,order,fluid_field_data_id,publisher_lang_id,publisher_status
352,162,161,16,0,0,0,1,0,1,open
353,162,161,16,0,0,0,1,0,1,draft
356,162,161,16,0,0,0,1,0,2,open
357,162,161,16,0,0,0,1,0,2,draft

exp_publisher_titles has eight related records
id,site_id,channel_id,author_id,entry_id,lang_id,status,title,url_title,page_url,hide_in_nav,template_id,parent_id,entry_date,edit_date,expiration_date,comment_expiration_date,edit_by
503,1,6,1,161,1,draft,Test Team Member EN,test-team-member,NULL,NULL,0,0,1585178340,1585178483,0,0,1
502,1,6,1,161,1,open,Test Team Member EN,test-team-member,NULL,NULL,0,0,1585178340,1585178483,0,0,1
505,1,6,1,161,2,draft,Test Team Member FR,test-team-member,NULL,NULL,0,0,1585178340,1585178544,0,0,1
504,1,6,1,161,2,open,Test Team Member FR,test-team-member,NULL,NULL,0,0,1585178340,1585178544,0,0,1
507,1,7,1,162,1,draft,Test Member EN,test-member,NULL,NULL,0,0,1585178580,1585178682,0,0,1
506,1,7,1,162,1,open,Test Member EN,test-member,NULL,NULL,0,0,1585178580,1585178682,0,0,1
509,1,7,1,162,2,draft,Test Member FR,test-member,NULL,NULL,0,0,1585178580,1585178850,0,0,1
508,1,7,1,162,2,open,Test Member FR,test-member,NULL,NULL,0,0,1585178580,1585178850,0,0,1

Custom Field Job Title has four related records
id,entry_id,field_id_13,lang_id,status,is_fluid
37,161,Job Title EN,1,draft,0
36,161,Job Title EN,1,open,0
39,161,Job Title FR,2,draft,0
38,161,Job Title FR,2,open,0

I don’t see any inconsistencies in the data. Please let me know if you notice any issues.

#6

BoldMinded (Brian)

Mar 26, 2020

Go to Publisher’s utilities page in the CP and see if all the hooks are correctly installed.

#7

eHealth Ontario

Mar 26, 2020

It says Good to go! It looks like all of Publisher’s hooks are installed and enabled.

#8

BoldMinded (Brian)

Mar 27, 2020

This isn’t something that hasn’t not worked in a long time, so I’m confused as to why you’re having this issue but I’m not (in my local env and on a large corporate site). I’ll setup a clean environment with a new Publisher install to try to replicate it. If I can’t replicate it there then I’m not sure what the next steps are. You don’t have any caching enabled of any kind? Have you tried to start fresh yourself with a new EE environment and Publisher install to try to replicate it again? I know this is a new install for you now, but if you start from scratch again and based on the result of that (if it works or doesn’t work), then it might provide some direction on how to further investigate this.

#9

BoldMinded (Brian)

Mar 27, 2020

Comment has been marked private.

Login to reply

Contact

For add-on support, please use the Support section. General inquries and pre-sale questions can be sent to support@boldminded.com.