Be sure to checkout our newest add-on Speedy!

EE compatibility updates:

  • Publisher is EE5 compatible, but it does not currently support the Fluid field.

ExpressionEngine.com licenses:

  • If you purchased an add-on from expressionengine.com, be sure to visit boldminded.com/claim to add the license to your account here on boldminded.com.

Ticket: Expiration date not read/parsed

Status Resolved
Add-on / Version Publisher Lite 3.1.3
Severity
EE Version 5.3.0

Hop Studios

Mar 12, 2020

I noticed a bug after we installed Publisher Lite where the expiration saved doesn’t matched the {expiration_date} tag in the template.

I saved 03/20/2020 as the expiration date and the entry didn’t show up in the channel entry loop. When I added, show_expired=“yes” I get the entry but the {expiration_date} is just 1. I then uninstalled Publisher and found that the expiration date is changed to 12/31/1969 4:00 PM.

I think this is enough for you to investigate the issue.

- Gilbert

#1

BoldMinded (Brian)

Mar 12, 2020

Brand new install or an upgrade?

#2

Hop Studios

Mar 12, 2020

Site was upgraded from 4 to 5 and Publisher Lite from 3.1.2 to 3.1.3.

- Gilbert

#3

BoldMinded (Brian)

Mar 13, 2020

I think this is related to a previous change you suggested. In Service/Entry/Entry.php, line 560 and 561, change them to this:

'expiration_date' => $defaultData['expiration_date'] ?? 0,
'comment_expiration_date' => $defaultData['comment_expiration_date'] ?? 0,
#4

Hop Studios

Mar 13, 2020

That seems to be it. I changed it and it is working now.

However, I noticed that the expiration_date set before installing publisher didn’t get translated to the Published/Draft copy.

I had an entry that for sure had expiration_date set as confirmed when I output it in the channel entry loop. I go to the edit screen and the expiration date field is blank. If I save the copy without specifying the expiration date, it will save and the expiration date will be null (or 0). The {expiration_date} is then 0 (which is the correct behaviour). However, I think it might be better that the expiration date field will show the original data rather than showing 0.

#5

BoldMinded (Brian)

Mar 16, 2020

I found the issue, but it will only be fixed for future installations. It wasn’t migrating the values.

Login to reply

Contact

For add-on support, please use the Support section. General inquries and pre-sale questions can be sent to support@boldminded.com.