All add-ons currently require PHP 7.4 or greater.

On July 4th 2024 PHP 8.2 will be the new minimum requirement for all add-ons. Expect any add-on released after that date to require 8.2 or greater. Some releases may not immediately take advantage of 8.x specific features in PHP, which means you might, be able to continue using new releases in PHP 7.4, however, if you experience an error the first thing you should do is update to PHP 8.2 then create a support ticket if the error persists.

Publisher does not support the Fluid field type. Please do not contact asking when support will be available.

If you purchased an add-on from expressionengine.com, be sure to visit boldminded.com/claim to add the license to your account here on boldminded.com.

Ticket: Keeps directing to the license page

Status Resolved
Add-on / Version Publisher Lite 3.1.2
Severity
EE Version 5.3.0

Hop Studios

Feb 20, 2020

Our client reported that when they tried to login to the CMS they get redirected to the Publisher license page (where we had already entered the correct license info).
They tried 2 different member group and one of them doesn’t even have Add-on access.

I was wondering if it’s a session error. Any idea?

- Gilbert

#1

BoldMinded (Brian)

Does the site have any firewall blocking access to license.boldminded.com? In your cache folder is there a “publisher_last_ping” file with a json object containing a timestamp in it?

#2

Hop Studios

I believe we don’t have firewall blocking access to licesne.boldminded.com… And when I save the license it gives me a success message. I think that’s kind of confirming that the verification is going through (and back)?

I did see a cache/publisher_last_ping file that has a json object containing a timestamp. Does this file expires?

#3

BoldMinded (Brian)

That file just marks the last time time a ping was made, basically every hour it tries to ping. Saving the license doesn’t actually call out to license.boldminded.com, its only when the page is reloaded and if an hour has passed since the last ping. Post in a private message the license key that you’re using and I’ll check to make sure it is in Elastic.

#4

Hop Studios

a:3:{s:4:"time";i:1582224117;s:3:"ttl";i:2400;s:4:"data";i:1582224117;}

This is what’s in the file.

#5

BoldMinded (Brian)

Gilbert, can you provide FTP and CP access to the site so I can debug it?

#6

BoldMinded (Brian)

I think I know what the issue is. I’ll send a new build soon.

#7

BoldMinded (Brian)

Comment has been marked private.

#8

Hop Studios

I see that there are many things changed in there. I’m currently testing something else on the staging site with the clients. On my local copy it looks good. I’ll let you know asap when I pushed it to staging site.

  • Gilbert
#9

BoldMinded (Brian)

Yeah, this is the build for the next release, so there are a few other things in there.

#10

BoldMinded (Brian)

The issue was Publisher Lite has a different ID in my database, but it was trying to validate using the full Publisher version ID, so the validation failed.

#11

BoldMinded (Brian)

Test comment

Login to reply