Be sure to checkout our newest add-on Speedy!

EE compatibility updates:

  • Publisher is EE5 compatible, but it does not currently support the Fluid field.

ExpressionEngine.com licenses:

  • If you purchased an add-on from expressionengine.com, be sure to visit boldminded.com/claim to add the license to your account here on boldminded.com.

Ticket: Fatal error: Uncaught Error after installation when trying to edit a channel or create a new field

Status Resolved
Add-on / Version Simple Grids & Tables 1.2.0
Severity
EE Version 5.3.0

pixi

Feb 17, 2020

Hi Brian,

Just bought Simple Grids & Tables and installed it on a brand new install, it only has Publisher installed the channels have been created but are still empty for now.
When trying to do some actions on the CP (edit a channel or create a new field for example), I got this error :

Fatal error: Uncaught Error: Call to a member function accepts_content_type() on boolean in /var/www/vhosts/my_path/ee/EllisLab/Addons/grid/libraries/Grid_lib.php:681 Stack trace: #0 /var/www/vhosts/my_path/ee/EllisLab/Addons/grid/libraries/Grid_lib.php(1001): Grid_lib->get_grid_fieldtypes() #1 /var/www/vhosts/my_path/ee/EllisLab/Addons/grid/libraries/Grid_lib.php(892): Grid_lib->getGridFieldtypeDropdownForColumn(NULL) #2 /var/www/vhosts/my_path/ee/EllisLab/Addons/grid/ft.grid.php(503): Grid_lib->get_column_view() #3 /var/www/vhosts/my_path/ee/EllisLab/Addons/grid/ft.grid.php(546): Grid_ft->getSettingsVars() #4 /var/www/vhosts/my_path/ee/legacy/libraries/api/Api_channel_fields.php(410): Grid_ft->display_settin in /var/www/vhosts/my_path/ee/EllisLab/Addons/grid/libraries/Grid_lib.php on line 681


If I rename the “simple_grids” folder on the FTP to kinda desactivate it, actions in the CP are normal.

Do you see the roots of this issue?

Thanks in advance.

 

 

#1

BoldMinded (Brian)

Feb 17, 2020

Don’t rename the simple_grids folder in the add-ons folder, EE will still try to load it. You have to move it out of the add-ons folder.

Do you have any other custom fieldtypes installed? Sounds like an error if an add-on doesn’t register as supporting grid correctly. You said it was a new install, but I think I need to ask you to do a fresh install of EE out of the box, don’t add any other add-ons or configure anything, then install Simple Grids & Tables and see if it installs correctly.

#2

pixi

Feb 17, 2020

Ok chief! :D

Just did what you asked : new installation with only simple grids & tables. Same issue.

#3

BoldMinded (Brian)

Feb 17, 2020

Did you have any custom fields created the first time you tried to install? If not, do you get the error after creating a new custom field then installing it?

#4

pixi

Feb 17, 2020

on the previous installation I had custom fields created prior to installing it but on this more fresh new installation I created a channel (not a field) and installed it, nothing more

#5

BoldMinded (Brian)

Feb 17, 2020

It’ll be a day or two until I can get a clean environment myself to replicate. I’m suspicious about this though b/c I’ve sold a decent number licenses for this and no one has reported a similar issue. If it was a wide spread fail to install issue, I would have heard about it before now.

#6

BoldMinded (Brian)

Feb 17, 2020

Basically what is happening is this call $fieldtype = $ft_api->setup_handler($field_short_name, TRUE); is returning null, so some other fieldtype is not getting instantiated correctly.

#7

pixi

Feb 18, 2020

Yes it is weird that it only happens to me. But I dont know what I could have done because basically I just installed EE and then installed Simple Grids & Tables (screenshot attached). Would it be a native fieldtype that not have been installed properly? And if so, how could it be possible?

#8

BoldMinded (Brian)

Feb 18, 2020

The image upload didn’t appear to work. I hopefully fixed the issue. Would you mind trying to re-attach the image?

#9

pixi

Feb 18, 2020

Just re-attached the images. Oh you already fixed the issue? Have you succeed to replicate it on your environnement then?

#10

BoldMinded (Brian)

Feb 18, 2020

sorry, I meant I hopefully fixed the image upload issue. I have not had a chance to replicate this yet.

#11

BoldMinded (Brian)

Feb 18, 2020

I just setup a brand new server with a new EE install from the 5.3 download from expressionengine.com, added Simple Grids & Tables, installed it, and no errors. I can go to the Create Channel page and Create Field page without error. I then created a channel, and a SG&T custom field, then created a new entry, still no error.

#12

pixi

Feb 19, 2020

Heck! Why can’t I? I’ll have to ask Slack community because I have no idea what to do. The thing is why does that happen only when Simple Grids & Tables is installed?

#13

BoldMinded (Brian)

Feb 19, 2020

Comment has been marked private.

#14

pixi

Feb 19, 2020

Unfortunately, it doesn’t change anything. I posted on Slack (no answers yet but I saw in some previous message before someone who has the same kind of error message for another reason). I hope I’ll find a solution because it is a show stopper for me, I really need Simple Grids for my project.

#15

BoldMinded (Brian)

Feb 19, 2020

What was the previous message that you found? Maybe if I see it it’ll jog my memory.

#17

BoldMinded (Brian)

Feb 19, 2020

I responded to that thread on Slack. Adrienne had the exact same error message you did, but her project did not have SG&T installed, so I think this is some other EE related issue, not a SG&T error.

#18

pixi

Feb 20, 2020

I added this line

if (empty($fieldtype)) { die($field_short_name); }

to line 680 of Grid_lib.php as Jace told Adrienne to do in her Slack thread to see which fieldtype doesn’t have a corresponding ft.adddon.php file and it gives me : simple_grid

#19

BoldMinded (Brian)

Feb 20, 2020

So do you see the ft.simple_grid.php and ft.simple_table.php files in system/user/addons/simple_grids folder?

#20

pixi

Feb 20, 2020

yes they are in the folder.

#21

BoldMinded (Brian)

Feb 20, 2020

I think at this point I’ll need a clean dev server to login to (cp and ftp), that has sg&t only installed and in the broken state since I can’t replicate it locally.

#22

BoldMinded (Brian)

Feb 20, 2020

You can edit the ticket and add the cp and fro info in the fields provided.

#23

pixi

Feb 21, 2020

Ok, I just did

#24

BoldMinded (Brian)

Feb 22, 2020

Ok, uninstall and re-install fixes it. It was not adding the rows to the exp_fieldtypes table. I think I know what is happening though… I think the license validation is preventing part of the install process from completing. I’ll try to replicate it locally and let you know if that is the case. At least for now it should be working though.

#25

pixi

Feb 24, 2020

Indeed it doesn’t produce the error anymore on this install, thanks. But how you uninstall totally an addon, you have to clean the DB since we don’t have an “unisntall” button? Can you tell me how to fix it on my real project installation so I can re-install it please? Or is it better to wait for an updated/fixed version from you?

#26

BoldMinded (Brian)

Feb 24, 2020

It did not add the rows to the exp_fieldtypes table. Running this query should fix it without an uninstall/re-install.

INSERT INTO `exp_fieldtypes` (`name`, `version`, `settings`, `has_global_settings`)
VALUES
 ('simple_table', '1.2.0', 'YTowOnt9', 'n'),
 ('simple_grid', '1.2.0', 'YTowOnt9', 'n');
#27

pixi

Feb 25, 2020

Ok, after this query the error is gone, thank you! This will be fixed in the next release? (if so, note for myself: don’t forget to dowload and update)

But I came across another issue with the toggle fields in simple grid…. You should be so happy right now :D I open another ticket for it.

#28

BoldMinded (Brian)

Feb 25, 2020

I hope I fixed it in the next release. I still wasn’t able to replicate it so we’ll see.

Login to reply

Contact

For add-on support, please use the Support section. General inquries and pre-sale questions can be sent to support@boldminded.com.