Be sure to checkout our newest add-on Speedy!

EE compatibility updates:

  • Publisher is EE5 compatible, but it does not currently support the Fluid field.

ExpressionEngine.com licenses:

  • If you purchased an add-on from expressionengine.com, be sure to visit boldminded.com/claim to add the license to your account here on boldminded.com.

Ticket: Issue with Pages saving

Status Resolved
Add-on / Version Publisher Lite 3.1.2
Severity
EE Version 5.3.0
Images

Ron Hickson

Feb 12, 2020

After updated to Publisher 3 when a new Pages module page is created (with the channel being Ignored) the publisher_site_pages table is not updated with the newly created Page resulting in a 404 trying to access the page.

#1

BoldMinded (Brian)

Feb 12, 2020

Ron, the next comment will have a link to a new build to try. I tested it and it seems to save fine, however, there still might be an edge case issue. The first time an ignored entry is saved it inserts the page data correctly, on subsequent saves, if you change the page url of an ignored entry, it does not update the non-default language page data, as intended b/c the channel is ignored in Publisher. It will update the default language values though. This may seem odd, but it’s just part of the logic…. an ignored channel doesn’t have translations. But, if you then go save an entry in a non-ignored channel, it’ll correct the urls of that ignored entry in the site pages array for non-default languages. Hopefully that makes sense :D

#2

BoldMinded (Brian)

Feb 12, 2020

Comment has been marked private.

#3

BoldMinded (Brian)

Feb 24, 2020

Ron, does the new build work? I’m going to mark this resolved, if it is still an issue just re-open the ticket.

Login to reply

Contact

For add-on support, please use the Support section. General inquries and pre-sale questions can be sent to support@boldminded.com.