All add-ons currently require PHP 7.4 or greater.

On July 4th 2024 PHP 8.2 will be the new minimum requirement for all add-ons. Expect any add-on released after that date to require 8.2 or greater. Some releases may not immediately take advantage of 8.x specific features in PHP, which means you might, be able to continue using new releases in PHP 7.4, however, if you experience an error the first thing you should do is update to PHP 8.2 then create a support ticket if the error persists.

Publisher does not support the Fluid field type. Please do not contact asking when support will be available.

If you purchased an add-on from expressionengine.com, be sure to visit boldminded.com/claim to add the license to your account here on boldminded.com.

Ticket: Redirect on template from one language to an other

Status Resolved
Add-on / Version Publisher 2.11.2
Severity
EE Version 5.3

Werner Gusset

Jan 22, 2020

We have a project where there was the second language English active for a short while. The default language is German and should be for the moment the only language. English is deactivated now.

Unfortunatly Google has the English Home link /en indexed among e few others /en URLS.
Now we have some of the false /en URLs redirected to the correct German page. So far so good.

But I am stucked with the redirect of the link domain.com/en to domain.com/de. I can not do that in the htaccess because of the other /en URLs we have redirects for.

Can I redirect on our home template from /en to /de? And how would I do that?

#1

BoldMinded (Brian)

Hi, Werner. This doesn’t sound like a fault or bug in Publisher. Sounds more like a custom scenario that you’ll need to work out on your own. You can try something like this, but this is about as much as I can suggest {if segment_1 == “” && publisher:current_language_code == “en”} {redirect=”/de”} {/if}

#2

Werner Gusset

Hi Brian, I know that it is not a bug of Publisher, that’s why it is a general question. Just thought you might know something out of experience. Your suggestion does not work. And I can now understand why. If there is no English language then there will not be an “en” value. Besides, /de is not a segment for EE redirects.

But it’s ok, I will sort it out myself.

Thanks for your time.

Login to reply