All add-ons currently require PHP 7.4 or greater.

On July 4th 2024 PHP 8.2 will be the new minimum requirement for all add-ons. Expect any add-on released after that date to require 8.2 or greater. Some releases may not immediately take advantage of 8.x specific features in PHP, which means you might, be able to continue using new releases in PHP 7.4, however, if you experience an error the first thing you should do is update to PHP 8.2 then create a support ticket if the error persists.

Publisher does not support the Fluid field type. Please do not contact asking when support will be available.

If you purchased an add-on from expressionengine.com, be sure to visit boldminded.com/claim to add the license to your account here on boldminded.com.

Ticket: History Data error

Status Resolved
Add-on / Version Bloqs 4.0.19
Severity
EE Version 5.2.2

Kathleen States

Nov 06, 2019

Hello,

I’m having an issue that is outputting an error statement from line 403 of bloqs/libraries/EEBlocks/Controller/TagController.php.

The error only happens when I turn nesting on for the field, and only on old blocks - if I delete all the old blocks and add a new one, things seem to work fine.
Is there any way to clear this data from the block, or am I not going to be able to use the nesting feature?

Thanks!

#1

BoldMinded (Brian)

Hi, Kathleen. Can you share the full error message? So you had an existing field with blocks, then enabled nesting, and the error displayed immediately when loading the edit page or after you tried to save the entry? I need more details on how to replicate the issue.

#2

BoldMinded (Brian)

Also you’re a few versions behind. Should upgrade first bc the issue could be fixed already.

#3

Kathleen States

Hi Brian, I’ve updated bloqs to the most recent version (4.1.1), and now I am getting this error:

Error An error occurred a nested Bloq field, probably because you forgot to add the {close:[block_name]}{/close:[block_name]} tag pair. Please refer to the documentation.

I tried removing all the fields and pasting in the vanilla code that is suggested to make sure there was nothing in my template causing it, but it’s still happening. It also happens if I take out everything inside exp:channel:entries. I’ve cleared my EE cache and my CE cache just in case as well.

#4

BoldMinded (Brian)

Can you provide CP access? Also point me to an entry this is happening in, which template file contains your entries code, and nothing else except for the single entries tag necessary to cause the error, and what URL I can trigger the error from on the front-end.

I may also need FTP access if I can’t find what is wrong by looking at the template.

Edit the ticket and add the CP access info in the provided fields. When the ticket is closed those values are erased from the database.

#5

Kathleen States

Aw, shoot, sorry for being a bother. Getting together a test page for you pinpointed where the issue was.

#6

BoldMinded (Brian)

Kathleen, is this still an issue? If I don’t hear back soon I’ll close the ticket.

Login to reply