All add-ons currently require PHP 7.4 or greater.

On July 4th 2024 PHP 8.2 will be the new minimum requirement for all add-ons. Expect any add-on released after that date to require 8.2 or greater. Some releases may not immediately take advantage of 8.x specific features in PHP, which means you might, be able to continue using new releases in PHP 7.4, however, if you experience an error the first thing you should do is update to PHP 8.2 then create a support ticket if the error persists.

Publisher does not support the Fluid field type. Please do not contact asking when support will be available.

If you purchased an add-on from expressionengine.com, be sure to visit boldminded.com/claim to add the license to your account here on boldminded.com.

Ticket: SQLSTATE[42000]: Syntax error or access violation: 1064 You have an error in your SQL syntax.

Status Resolved
Add-on / Version Publisher 3.0.0
Severity
EE Version 5.3.0

Riccardo Melzi

Nov 05, 2019

Hello,
I’ve just updated your module and I get this error when I try to open a specific channel.
The entries of any other channel works fine.

If you can access to CP with the login details I provide you, try to edit any entries in “Models” channel.

It looks like the entry id is missing in the sql query: [... exp_publisher_data_field_104.status WHERE `t`.`entry_id` IN () ]

Let me know if you need any other info
Thanks
Riccardo

 

 

#1

BoldMinded (Brian)

Comment has been marked private.

#2

Riccardo Melzi

Comment has been marked private.

#3

BoldMinded (Brian)

Can you share what the entries tag looks like that is throwing that error? Just the opening tag pair with all the parameters.

#4

BoldMinded (Brian)

You also provided a domain but did not mention what template this is occurring in or what url I can see the error happen at. It’s best if you create a new template that has nothing in it but the entries tag that is causing the problem.

#5

Riccardo Melzi

Comment has been marked private.

#6

BoldMinded (Brian)

Can you provide FTP access to that environment so I can do some debugging? If so edit the ticket and add the creds in the provided fields.

#7

Riccardo Melzi

Comment has been marked private.

#8

BoldMinded (Brian)

I just removed the info from your comment. As mentioned, please edit the ticket and add the info in the fields provided. When the ticket is closed, those fields are erased from the database. I don’t want FTP information hanging out in comments forever. Thanks.

#9

BoldMinded (Brian)

You don’t need to do anything, when I click Resolve ticket it will immediately delete the FTP info from the database.

#10

BoldMinded (Brian)

Should be fixed now. Check it out to see if everything is looking correct. The issue is that it was trying to find the draft version of those entries, which did not exist.

#11

Riccardo Melzi

It works now. Thank you so much. Riccardo

#12

Riccardo Melzi

Hello Brian, I added a new language, but when I save the entries the translation is not saved. Can you take a look? I updated the FTP access details. Thanks Riccardo

#13

Riccardo Melzi

Comment has been marked private.

#14

BoldMinded (Brian)

Comment has been marked private.

Login to reply