All add-ons currently require PHP 7.4 or greater.

On July 4th 2024 PHP 8.2 will be the new minimum requirement for all add-ons. Expect any add-on released after that date to require 8.2 or greater. Some releases may not immediately take advantage of 8.x specific features in PHP, which means you might, be able to continue using new releases in PHP 7.4, however, if you experience an error the first thing you should do is update to PHP 8.2 then create a support ticket if the error persists.

Publisher does not support the Fluid field type. Please do not contact asking when support will be available.

If you purchased an add-on from expressionengine.com, be sure to visit boldminded.com/claim to add the license to your account here on boldminded.com.

Ticket: When I run the cronjob, it never completely runs when “delete old entries” not updated by import.

Status Resolved
Add-on / Version DataGrab 4.2.2
Severity
EE Version 7

tony williams

Apr 12, 2023

When running the crob job, DataGrab never finishes running (“wating”) when delete old entries when not in import.

 

#1

BoldMinded (Brian)

Tony, would you be interested in trying the new version of DG that is in beta? Version 5 might just fix this issue for you.

Are you in the EE Slack channel?

#2

tony williams

No, but yes I would like to try Version 5

#3

tony williams

Comment has been marked private.

#4

BoldMinded (Brian)

Comment has been marked private.

#5

tony williams

DataGrab 5 does not have the path settings of “Data/Rows” so it was not successful for us…we received a fix (datagrab-4.2.2-develop-21627580) and the fix is not available in the beta 5.

I’m hoping for a solution….thanks!

#6

BoldMinded (Brian)

I don’t know what this means: DataGrab 5 does not have the path settings of “Data/Rows”

Can you elaborate and share a screenshot?

#7

BoldMinded (Brian)

Ah, hold on. I think I sent you a slightly older build of v5.

#8

BoldMinded (Brian)

Comment has been marked private.

#9

tony williams

Comment has been marked private.

#10

BoldMinded (Brian)

Comment has been marked private.

#11

tony williams

Comment has been marked private.

#12

BoldMinded (Brian)

What version of PHP are you using?

#13

BoldMinded (Brian)

Remove the last comma after the 0 at 0 // rest on line 121

#14

tony williams

7.4-38

#15

tony williams

Now we are receiving a possible PHP issue but we are running 7.4 and other issues that I have attached.

#16

BoldMinded (Brian)

The message says you’re using PHP 7.2.34, are you sure your PHP (both CLI and Apache versions) are running 7.4?

#17

tony williams

We are running PHP 8 (verified) but we are still receiving a php version PHP_VERSION_ID on line 7 pulls up version 7.2

this platform check file keeps pulling up the wrong version vendor-build/composer/platform_check.php

also, how do we know what EE CLI version we are running?

#18

BoldMinded (Brian)

Are you actually running the imports from inside your CP or via the CLI? I can’t really tell where the “hello this script is running” error messages are coming from b/c they’re cropped.

#19

tony williams

Yeah, it’s a bash script being run on the cloud server

Login to reply