All add-ons currently require PHP 7.4 or greater.

On July 4th 2024 PHP 8.2 will be the new minimum requirement for all add-ons. Expect any add-on released after that date to require 8.2 or greater. Some releases may not immediately take advantage of 8.x specific features in PHP, which means you might, be able to continue using new releases in PHP 7.4, however, if you experience an error the first thing you should do is update to PHP 8.2 then create a support ticket if the error persists.

Publisher does not support the Fluid field type. Please do not contact asking when support will be available.

If you purchased an add-on from expressionengine.com, be sure to visit boldminded.com/claim to add the license to your account here on boldminded.com.

Ticket: EE Auto-update fails due to Publisher polling APP_VER constant in addon.setup.php file.

Status Resolved
Add-on / Version Publisher 3.8.2
Severity
EE Version 6.3.5

Gavin @ JCOGS

Feb 08, 2023

Hi

EE auto-update fails - reports issue with APP_VER being undefined.

In this thread from Slack - https://eecms.slack.com/archives/C04CUNNR9/p1675855500473409 - Yuri observes that this is caused by an add-on polling the APP_VER constant from within the addon.setup.php file - something apparently not encouraged on the plausible basis that APP_VER is not defined when the updater script is running.

Upon checking, it turns out that the issue is being caused by Publisher - which on line 431 of its addon.setup.php file does poll the APP_VER value.

Would be good if this could be fixed…

#1

BoldMinded (Brian)

I’ve auto updated the last several versions of EE 6 and 7 wit publisher installed and never ran into this error. I’m wondering why you’re getting it though.

#2

Gavin @ JCOGS

No idea, but commenting out the conditional on the line cited (and leaving just the line for EE6) removed the error and allowed the update to go ahead. Suggest you have a conversation with Yuri perhaps?

#3

BoldMinded (Brian)

I’ll work with the EE team on this. Thanks

Login to reply