Publisher is EE6 compatible, but it does not support the Fluid field. Please do not contact asking when support will be available.

If you purchased an add-on from expressionengine.com, be sure to visit boldminded.com/claim to add the license to your account here on boldminded.com.

Ticket: Datagrab Installation Error

Status Resolved
Add-on / Version DataGrab 4.0.5
Severity
EE Version 6.2.2

sam.royama

Aug 26, 2022

Hi, received this error when installing Datagrab:

Exception Caught
SQLSTATE[42S22]: Column not found: 1054 Unknown column 'import_status' in 'field list':
SELECT `id`, `name`, `description`, `passkey`, `import_status`, `import_lastrecord`, `import_totalrecords`, `last_run`, `settings` FROM (`exp_datagrab`) WHERE `site_id` = 1 ORDER BY `name` ASC
ee/legacy/database/drivers/mysqli/mysqli_connection.php:114

Stack Trace: Please include when reporting this error
#0 ee/legacy/database/drivers/mysqli/mysqli_driver.php(112): CI_DB_mysqli_connection->query('SELECT `id`, `n…')
#1 ee/legacy/database/DB_driver.php(260): CI_DB_mysqli_driver->_execute('SELECT `id`, `n…')
#2 ee/legacy/database/DB_driver.php(175): CI_DB_driver->simple_query('SELECT `id`, `n…')
#3 ee/legacy/database/DB_active_rec.php(1076): CI_DB_driver->query('SELECT `id`, `n…')
#4 user/addons/datagrab/mcp.datagrab.php(89): CI_DB_active_record->get('exp_datagrab')
#5 [internal function]: Datagrab_mcp->index()
#6 ee/ExpressionEngine/Controller/Addons/Addons.php(1489): call_user_func_array(Array, Array)
#7 ee/ExpressionEngine/Controller/Addons/Addons.php(797): ExpressionEngine\Controller\Addons\Addons->getModuleSettings('datagrab', 'index', Array)
#8 [internal function]: ExpressionEngine\Controller\Addons\Addons->settings('datagrab')
#9 ee/ExpressionEngine/Core/Core.php(257): call_user_func_array(Array, Array)
#10 ee/ExpressionEngine/Core/Core.php(113): ExpressionEngine\Core\Core->runController(Array)
#11 ee/ExpressionEngine/Boot/boot.php(161): ExpressionEngine\Core\Core->run(Object(ExpressionEngine\Core\Request))
#12 public_html/admin.php(144): require_once('...')
#12 public_html/admin.php(144): require_once('...')

Currently running: EE 6.2.2, PHP 8.1, Datagrab 4.0.5

#1

BoldMinded (Brian)

Aug 26, 2022

You should upgrade to EE 6.3.x at least. I don’t think it’s related to this error, but technically according to my support terms your install of EE is to old.

I’ll try to replicate this locally and get back to you.

#2

BoldMinded (Brian)

Aug 26, 2022

Did you upgrade from a previous version of DataGrab and/or EE?

#3

BoldMinded (Brian)

Aug 26, 2022

So that import_status field was added to DataGrab back in version 1.9.1… a long time ago. I’m guessing a previous update didn’t succeed or something? Do you see a import_lastrecord and import_totalrecords column in your exp_datagrab table?

#4

BoldMinded (Brian)

Aug 26, 2022

If this is the case, it might be easiest to uninstall and re-install it from scratch. If you do that, you can copy the contents and make a backup of the settings column in the exp_datagrab table, uninstall it, re-install it, then paste the value of the settings back into the appropriate row without having to point and click reconfigure each import.

#5

sam.royama

Aug 31, 2022

Hi Brian, thanks for your help with this. I updated EE to 6.3.5 on a staging server and Datagrab installed just fine. I ran through the upgrade process for the live site and the addon appears to be working as intended. Not sure exactly what was the issue. I’m running into an error with another plugin on the live server, but not the staging server, so I suspect something is slightly amiss. I’ll track it down. If I have any further insight that relates to this issue, I’ll post. Thanks.

Login to reply