Publisher is EE6 compatible, but it does not support the Fluid field.

If you purchased an add-on from expressionengine.com, be sure to visit boldminded.com/claim to add the license to your account here on boldminded.com.

Ticket: Ordeby Atoms

Status Resolved
Add-on / Version Bloqs 541
Severity
EE Version 6.0.1

Dave de Bruin

Jun 24, 2021

Hi Brian,

I’ve asked this in Slack some time ago.. but still hoping fro a solution..

I have a channel with lessons, these lessons have a bloqfield with an atom called homework which consist of a date-field and a tex-field.
I was wondering if it was possible to order the entries bij the date-field of the atom ‘homework’.

You said it couldn’t be done, but is there a workaround by using a query or something?

Loving Bloqs by the way!

Best regards Dave

#1

BoldMinded (Brian)

Jun 24, 2021

There may be a way to do it with a query, but I don’t know what that would look like. The problem is that you can have multiple atoms with the same name but in different bloqs, and Bloqs isn’t really designed to change the order of bloqs on output. It’s a page builder, so what you put into the CP is what you get on the front-end.

This isn’t something I’m going to add native support for. You could look at using Stash and it’s lists…. iterate the bloqs, capture the values you want, and then you can output the list based on a sort value. https://github.com/croxton/Stash/wiki/Lists

#2

Dave de Bruin

Jun 24, 2021

Thanks Brain, I will trie to stash it.
If it works I let you know.

Have a nice day

Login to reply