EE compatibility updates:

  • Publisher is EE5 compatible, but it does not currently support the Fluid field.

ExpressionEngine.com licenses:

  • If you purchased an add-on from expressionengine.com, be sure to visit boldminded.com/claim to add the license to your account here on boldminded.com.

Ticket: Publisher previews not always working

Status Resolved
Add-on / Version Publisher Lite 3.2.3
Severity
EE Version 5.3.2

James Brown

Jan 20, 2021

I’m having an issue where a preview will just randomly stop working for an entry. If it is a draft of a live page the preview URL will just show the live page instead of the draft. In most cases the preview will work for some period of time and then stop working. I don’t exactly have steps to reproduce it as it seems to be random. But here’s a couple examples:

1. I’ll “Save Draft & Preview”. The preview will come up in the control panel. I’ll open it in a new window and the draft is showing. I’ll share the URL with someone to review the draft content. They’ll see the live content instead of the draft content. I’ll check the link and I’ll see the live content as well.

2. I’ll “Save Draft & Preview”. The preview will come up in the control panel. I’ll open it in a new window and the draft is showing. I’ll come back to the link maybe 30 minutes later and refresh. The live content is showing rather than the draft content.

3. I’ll “Save Draft & Preview”. The preview will come up in the control panel. I’ll right click on the preview link and have it open in a new window. The draft content will not be shown, just the live content. That one has only happened a handful of times.

#1

BoldMinded (Brian)

Jan 21, 2021

James, thanks for the text description, but that is still a little hard to follow. Any chance you could capture this on video? Or provide screenshots of your Publisher settings pages (specifically the ones dealing with drafts and previews). Thanks.

Login to reply