EE compatibility updates:

  • Publisher is EE5 compatible, but it does not currently support the Fluid field.

ExpressionEngine.com licenses:

  • If you purchased an add-on from expressionengine.com, be sure to visit boldminded.com/claim to add the license to your account here on boldminded.com.

Ticket: Field tags doesn’t output any code

Status Resolved
Add-on / Version Reel 1.4.2
Severity
EE Version 5.3.2

Johan Hedin

May 04, 2020

Field tags doesn’t output any code.  For example, if I use the (field_name:width) field tag I get nothing. The only field tag that output anything is the {field_name} that should output the full iframe embed code. However this is the only thing it output:

<iframe src="https://www.youtube.com/embed/hlWiI4xVXKY?rel=0&wmode=opaque" border="0"></iframe>

This results in a very tiny video viewport.

In CP everything seem to work just fine. I can search Youtube and Vimeo and preview in publish looks good. I have reinstalled and reuploaded everything. The documentation for this product is rather sparse. There is no template examples etc. maybe I missed something? I don’t know.

 

#1

BoldMinded (Brian)

May 04, 2020

The iframe code you showed is working as intended as the output of {field_name}. I’ll take a look at the :width modifier, but last I checked those modifiers were working. Another options is you can also just use {field_name:video_id} and create your own embed tag and not rely on Reel to do it for you.

#2

BoldMinded (Brian)

May 04, 2020

I just did a test with the same video, and the width and height values are not present in the data returned from YT. It is possible those are old attributes that have been deprecated from their API. I suggest making your own embed tag using the video_id and setting the width and height to the values best suited for rendering on your site.

#3

Johan Hedin

May 04, 2020

Ahh, okay. I tested the {field_name:video_id} and it works. I’ll work with that! /thanks

Login to reply

For add-on support, please use the Support section. General inquries and pre-sale questions can be sent to support@boldminded.com.