Be sure to checkout our newest add-on Speedy!

EE compatibility updates:

  • Publisher is EE5 compatible, but it does not currently support the Fluid field.

ExpressionEngine.com licenses:

  • If you purchased an add-on from expressionengine.com, be sure to visit boldminded.com/claim to add the license to your account here on boldminded.com.

Ticket: Updated data not saved in publisher tables

Status Resolved
Add-on / Version Publisher Lite 3.1.1
Severity
EE Version 5.3.0

Ron Hickson

Dec 27, 2019

When I update an entry in an ignored channel the updated information is saved to the exp_channel_ tables correctly and then promptly overwritten during the extension method `after_channel_entry_update`.  After digging around a bit it appears that the data is not saved to exp_publisher_ tables during the `after_channel_entry_save` method.  This is occurring with custom fields as well as default fields.

#1

BoldMinded (Brian)

Dec 27, 2019

Ron, from what I can tell it is working as intended. What actual issue are you experiencing with the ignored channel setting?

#2

Ron Hickson

Dec 27, 2019

It seems that when I enable ignores (which the settings do fine) upon then editing an entry in an ignored channel the newly saved entry loses its field data and the default fields remain unchanged.  A simple example is that trying to change the entry date only results in the original entry date still being in existence.  This doesn’t happen when creating a new entry or updating a newly created entry - only when updating an entry that existed prior to upgrading to Publisher 3.0.

#3

Ron Hickson

Dec 27, 2019

Just occurred to me that mentioning this is a Publisher 1.7.5 getting upgraded to Publisher 3.1.1 is really relevant.  A major EE update from 2 to 5 was done.  I’m glad to run the last version of Publisher 2 and see if that does differently - perhaps something in the particular upgrade path is scrambling.

#4

BoldMinded (Brian)

Dec 28, 2019

Yeah, this appears to be an issue with the upgrade process. It shouldn’t have created records in the new exp_publisher_data_field_X tables for entries in ignored channels. I think the only way to fix this is to run a delete query to remove the data from the exp_publisher_data_field_X tables. Do you know all of the field IDs for fields assigned to that ignored channel?

#5

BoldMinded (Brian)

Dec 28, 2019

After looking into this a little more I’m curious how this happened because if a channel is ignored, it won’t have any data in the exp_publisher_titles or exp_publisher_data tables, thus if there is nothing in exp_publisher_data prior to the upgrade to v3, it won’t create rows in the exp_publisher_data_field_X tables. Was this table previously not ignored? Was it one that you originally had drafts or translations in then decided to ignore it?

#6

Ron Hickson

Dec 30, 2019

The channels have been ignored but I did notice that upon upgrade to EE 3 the new “Enable Ignores” was not active.  But even beyond that I thought that originally Publisher still created content in the exp_publisher_data and exp_publisher_titles tables for ignored channels (they just didn’t have draft status) and this site has been running Publisher quite some time.  Based on your comments the easiest solution for me (at least worth trying) sounds like dropping any entries in the ignored channels from the exp_publisher_data and exp_publisher_titles tables before running the Publisher 3 upgrade.  Thoughts?

#7

BoldMinded (Brian)

Dec 30, 2019

Yeah, that might be your best approach. Maybe waaaaay back in the day a version of Publisher actually did create entries for ignored channels, but for quite some time now the logic actually stops Publisher from saving any data in ignored channels, and it does know how to fall back to the native EE tables for data.

#8

Ron Hickson

Dec 31, 2019

A few queries to remove ignored channel data before the migration to Publisher 3 ran and all seems to be well.  I’ll chalk it up to “cruft” from something way back - we’ve been running Publisher since 2013 (version 1.0.15).  Thanks for the help.

Login to reply

Contact

For add-on support, please use the Support section. General inquries and pre-sale questions can be sent to support@boldminded.com.