Be sure to checkout our newest add-on Reading Time Pro!

Compatibility updates:

  • Publisher is EE5 compatible, but it does not currently support the Fluid field (it's in the works).

Ticket: Getting error while going to Install after EE update

Status Resolved
Add-on / Version Bloqs 4.0.21
Severity
EE Version 5.2.4

James Logan

Jul 23, 2019

I updated an ExpressionEngine website from v2.11.3 to v5.2.4. I followed the same steps as mentioned here for EE update https://eebloqs.com/documentation/getting-started but I am getting error while click on Install button. Please see screenshot.

Please help me to resolve this issue.

#1

BoldMinded (Brian)

Jul 23, 2019

James, I don’t see a screenshot attached. Can you copy/paste the error instead?

#2

James Logan

Jul 23, 2019

It seems screenshot isn’t uploading. Please see error message as below:

—————————-
Fatal error: Uncaught Error: Class ‘EEBlocks\Controller\HookExecutor’ not found in /Users/bhashkar/Sites/expression-engine/intertain/ee-project-1/system/user/addons/bloqs/mcp.bloqs.php:70 Stack trace: #0 /Users/bhashkar/Sites/expression-engine/intertain/ee-project-1/system/ee/EllisLab/ExpressionEngine/Controller/Addons/Addons.php(1638): Bloqs_mcp->__construct() #1 /Users/bhashkar/Sites/expression-engine/intertain/ee-project-1/system/ee/EllisLab/ExpressionEngine/Controller/Addons/Addons.php(946): EllisLab\ExpressionEngine\Controller\Addons\Addons->getModuleSettings(‘bloqs’, ‘index’, Array) #2 [internal function]: EllisLab\ExpressionEngine\Controller\Addons\Addons->settings(‘bloqs’) #3 /Users/bhashkar/Sites/expression-engine/intertain/ee-project-1/system/ee/EllisLab/ExpressionEngine/Core/Core.php(241): call_user_func_array(Array, Array) #4 /Users/bhashkar/Sites/expression-engine/intertain/ee-project-1/system/ee/EllisLab/ExpressionEngine/Core/Core.php(110): EllisLab\ExpressionEngine\Core\Core->runController(Array) #5 /Users/ in /Users/bhashkar/Sites/expression-engine/intertain/ee-project-1/system/user/addons/bloqs/mcp.bloqs.php on line 70

#3

BoldMinded (Brian)

Jul 30, 2019

James, I thought I already replied to this, maybe I did in an email, but usually that error occurs if some files have not been installed correctly, or the add-on is having trouble loading the Composer autoloader. The zip file is correct and has all the files… are you using Composer elsewhere on your site?

#4

BoldMinded (Brian)

Sep 04, 2019

James, I’m just following up on this ticket, did you get it sorted out?

#5

BoldMinded (Brian)

Oct 05, 2019

Closing due to inactivity.

Login to reply

Contact

For add-on support, please use the Support section. General inquries and pre-sale questions can be sent to support@boldminded.com.