Be sure to checkout our newest add-on Reading Time Pro!

EE4 compatibility updates:

  • Publisher is EE4 and EE5 compatible, but it does not currently support the Fluid field (it's in the works).
  • Reel is EE4 and EE5 compatible, but it does not currently support the Fluid field.

Ticket: Publisher triggers an error in Channel Images add-on fields under certain settings

Status Resolved
Add-on / Version Publisher 2.7.9
Severity
EE Version 3.5.16

Edoardo Stefani

Jan 31, 2019

I’m experiencing trouble with Channel Images fields and i came up to the conclusion that somenthing is wrong between CI e Publisher, but i couldn’t say for sure who is the culprit.
Channel Images stopped working reporting a generic php error during upload. I debugged the Channel Images plugin going nowhere, ‘cause no error has been found in any log and the hook of the router was never being called. Plus, the Channel Images field was failing to validate location showing the homepage instead of the proper output.
Moving forward: testing in a local environment the validate location feature of Channel Images showed a warning triggered at

\system\ee\legacy\libraries\Cache\drivers\Cache_file.php line 120

  about the inability to write the file in the Publisher cache folders. Sorry to not be able to share the detailed log.

These the steps i took since then:
- disabled Publisher. Channel Images working.
- enabled Publisher using the default settings. Channel Images working.
- tested the settings i was using on the live site, meaning “add url prefix” to ON under “Url translation” and boom, the error on Channel Images popped out.
- saying to Publisher to ignore the Channel_Images fields didn’t solve the issue.

The bug has been observed 3 different environments.

Further details:
Channel Images: 6.0.4
Gzip: disabled
Cache method: file (can’t be turned off, since is a Channel Images requirement)

#1

BoldMinded (Brian)

Jan 31, 2019

Thanks for the details, but you left out the most crucial part… what is the error message you’re getting?

#2

Edoardo Stefani

Jan 31, 2019

Hello Brian and thanks for replying so quickly.

Trying to upload a file through the Channel Images field ends up with useless

"Server response was not as expected, probably a PHP error. OPEN ERROR"

where open error is not clickable. Inspecting the ajax upload call shows that the returned response is the html code of the homepage.

About the warning on validating location inside the Channel Images field:
I don’t remind the exact message. At the moment i am not able to see it again.
What i remind is something like “unable to write” in

system/user/cache/md/publisher/lang/1/status/open/get_translated_url/1/1

The warning is repeating and given for similar paths.
The reported folders have permissions on 755 and contain Publisher’s regular files.

#3

BoldMinded (Brian)

Jan 31, 2019

When I login to your CP with the info you provided, what channel and what entry can I look at to see the issue occur?

I’ll take a quick look at this, but Publisher has never supported Channel Images. It’s up to CI to support Publisher.

#4

BoldMinded (Brian)

Jan 31, 2019

You’re also on EE3, which I don’t support anymore for any add-ons since it is retired software.

#5

BoldMinded (Brian)

Jan 31, 2019

There is also another issue happening here that you’ll need to resolve first. This is what the response is when I click OPEN ERROR https://d.pr/i/M31huV

#6

BoldMinded (Brian)

Jan 31, 2019

When I upload an image it is first making a request to ?ACT=27 on your site, which Publisher is specifically setup to ignore. It stops all URL or translation processing if the URL contains “ACT” as a GET parameter. It looks like Channel Images is erroring out in some other way, and it’s re-directing, which eventually ends up at https://eetest.studioaf.eu/en.

I’m pretty certain this is not caused by Publisher.

#7

Edoardo Stefani

Feb 01, 2019
There is also another issue happening here that you’ll need to resolve first. This is what the response is when I click OPEN ERROR <a href="https://d.pr/i/M31huV">https://d.pr/i/M31huV</a>

ok, however is not relevant

When I upload an image it is first making a request to ?ACT=27 on your site, which Publisher is specifically setup to ignore. It stops all URL or translation processing if the URL contains “ACT” as a GET parameter. It looks like Channel Images is erroring out in some other way, and it’s re-directing, which eventually ends up at <a href="https://eetest.studioaf.eu/en">https://eetest.studioaf.eu/en</a>.

The ?ACT=27 never reachs the Channel Images hook because something fails before (and that’s why it ends up loading the homepage).
The CI failure happens when the lang prefix setting is turned on in Publisher. How do you explain this behavior?

I read some old posts where you were in contact with the Channel Images dev for Publisher integration.
If you can, please share how to contact him, i wasn’t able to get a reply to the ticket i opened 2 weeks ago.

Anyhow, thanks for taking the time to dig into this, i apprecciate it.

 

 

 

#8

BoldMinded (Brian)

Feb 04, 2019

I tried to replicate this locally and can’t do so. I’d suggest taking a look at installing a new version of EE and Publisher, and perhaps in a new environment, to see if you can replicate it. And also take a look at your server config (htaccess re-writes etc). As I mentioned before in your environment it appears to be calling the file upload action correctly (ACT=27, then from there it redirects incorrectly).

My Publisher settings: https://d.pr/i/WAMZWn
CI field after uploading an image: https://d.pr/i/AY3TBn

#9

BoldMinded (Brian)

Feb 04, 2019

Here is a video of it working https://d.pr/i/kp8J6d

#10

Edoardo Stefani

Feb 05, 2019

I’m starting to think to rebuild the website on a newest EE release. Thanks Brian, even if the problem hasn’t been solved you’ve been helpful

Login to reply

Contact

For add-on support, please use the Support section. General inquries and pre-sale questions can be sent to support@boldminded.com.