Be sure to checkout our newest add-on Reading Time Pro!

Compatibility updates:

  • Publisher is EE5 compatible, but it does not currently support the Fluid field (it's in the works).

Ticket: It returns error after the Bloqs is updated to 4.0.15 on EE 5.0.2

Status Resolved
Add-on / Version Bloqs 4.0.15
Severity
EE Version 5.0.2

Dan Munday

Dec 20, 2018

Hi Brian,
After I updated the Bloqs to 4.0.15, it returns the following error message on the Entry Form.

Content Blocks

Fatal error: Uncaught Error: Call to undefined method Basee\App::isGteEE4() in /Users/chris/Documents/Websites/harthouse/_site/system/user/addons/bloqs/libraries/EEBlocks/Controller/PublishController.php:456 Stack trace: #0 /Users/chris/Documents/Websites/harthouse/_site/system/user/addons/bloqs/libraries/EEBlocks/Controller/PublishController.php(179): EEBlocks\Controller\PublishController->publishAtom(1313, Object(EEBlocks\Model\AtomDefinition), 38, ‘blocks_block_id…’, ‘Welcome’) #1 /Users/chris/Documents/Websites/harthouse/_site/system/user/addons/bloqs/libraries/EEBlocks/Controller/PublishController.php(99): EEBlocks\Controller\PublishController->renderBlock(38, Object(EEBlocks\Model\Block)) #2 /Users/chris/Documents/Websites/harthouse/_site/system/user/addons/bloqs/ft.bloqs.php(202): EEBlocks\Controller\PublishController->displayField(38, Array, Array) #3 /Users/chris/Documents/Websites/harthouse/_site/system/ee/legacy/fieldtypes/EE_Fieldtype.php(326): Bloqs_ft->display_field(’ ‘) #4 /Users/chris/Documents/Websites/ in /Users/chris/Documents/Websites/harthouse/_site/system/user/addons/bloqs/libraries/EEBlocks/Controller/PublishController.php on line 456

#1

Dan Munday

Dec 20, 2018

Hi Brian,
one more note. The stable Bloqs version on my local dev is 4.0.7. I did update the Bloqs to 4.0.13 but still returned the error message.
I did not install Publisher at all. Is the error related to the Publisher?
Chris

#2

BoldMinded (Brian)

Dec 20, 2018

Dan, this is probably b/c you have another one of my add-ons installed but have not updated them, probably Publisher or Simple Grids & Tables? Upgrade those too and the issue should be resolved.

#3

BoldMinded (Brian)

Dec 20, 2018

I did not install Publisher at all. Is the error related to the Publisher?

Yes, if you have Publisher’s files, but it’s not actually installed, then it may still cause the error. Just grab the latest version.

#4

Dan Munday

Dec 20, 2018

Thanks let me try. BTW I am Chris.

#5

Dan Munday

Dec 20, 2018

Hey Brian,
I did not install Publisher but i did install the latest Simple Grids and Tables.
Still returns errors
Chris

#6

BoldMinded (Brian)

Dec 20, 2018

This has come up a few times already, I’m 99.99999% certain it’s b/c you have the files from one or more old versions of one of my add-ons, or there is a slim possibility that the server is caching PHP files or something.

https://boldminded.com/support/ticket/1884
https://boldminded.com/support/ticket/1893

#7

Dan Munday

Dec 20, 2018

Brian, While I did purchase Publisher, but i really did not install it at all. In this case, do you still want me to install Publisher?

#8

BoldMinded (Brian)

Dec 20, 2018

No, don’t install it if you don’t need it. You can put add-on files into a project without actually installing it by clicking the Install button in the control panel. Did you put the files into user/addons though? If Publisher’s files are in the project, but it is not installed, then remove the files from the project.

#9

Dan Munday

Dec 20, 2018

There is nothing about Publisher in all the folders though. I did not even download the add-on since I purchased it.

#10

Dan Munday

Dec 20, 2018

Believe it or not. I have one default EE site for only testing your add-on. The Bloqs is 4.0.7 and I also installed Simple Grid and TJ’s Construct. After i updated to 4.0.15 it has the same error message again.
Chris

#11

BoldMinded (Brian)

Dec 20, 2018

What is the listing of add-ons you have installed? Are you 110% positive all of the Bloqs files have been replaced with the old files?

#12

BoldMinded (Brian)

Dec 20, 2018

The Bloqs is 4.0.7 and I also installed Simple Grid

Did you upgrade Simple Grids and Tables to the latest version too?

#13

Dan Munday

Dec 20, 2018

Yes.

#14

BoldMinded (Brian)

Dec 20, 2018

Simple Grids & Tables is up to version 1.0.3, which should fix the issue.

#15

Dan Munday

Dec 20, 2018

according to your website, it is 1.0.2, right?

#16

Dan Munday

Dec 20, 2018

but my account only has 1.0.2 only

#17

Dan Munday

Dec 20, 2018

May you send me 1.0.3 as it does not available in my account. thanks

#18

BoldMinded (Brian)

Dec 20, 2018

It looks like I forgot to actually upload 1.0.3. Check your account now.

#19

Dan Munday

Dec 20, 2018

it works now. thanks

Login to reply

Contact

For add-on support, please use the Support section. General inquries and pre-sale questions can be sent to support@boldminded.com.