EE4 compatibility updates:

  • Publisher is EE4 and EE5 compatible, but it does not currently support the Fluid field.
  • Reel is EE4 and EE5 compatible, but it does not currently support the Fluid field.

Ticket: Publisher seems to generate empty Ansel fields / grid fields

Status Resolved
Add-on / Version Publisher 2.10.3
Severity
EE Version 5.0.1

Matthias Ballmann

Nov 28, 2018

hi brian,

on this new museum website we have an issue for months were we thought it could an ansel problem … but we are now thinking it must have something to do with publisher.
the site uses two languages, german and english.

The phenomenon looks like this: when we save a channel entry in the English version, empty image fields appear in the entries of that channel. If we then switch to the German version, the additional field is still there, but also empty. So only the number of fields is doubled, but not their contents.

If we save the entry in the German version, this does not happen – everything is quite normal there.
The number of fields doubles constantly, so that after saving the English version three times, you can see 8 fields, for example.

I remember that this or a similar error occurred some time ago - at that time also with a grid field. So we think it has nothing to do with Ansel.


Thank you
and kindest regards,
Matthias

#1

BoldMinded (Brian)

Nov 28, 2018

Matthias, this is definitely an Ansel problem. The fieldtype needs to support Publisher, not the other way around. I can’t natively add and support integration for all other fieldtypes into Publisher, its just too much to handle. I don’t think TJ has added Publisher support to Ansel, and it sounds like he doesn’t plan on adding support until version 3 of Ansel.

#2

Matthias Ballmann

Dec 03, 2018

ok, I wrote an email to tj.
I already did this weeks ago but he didn’t seem to understand what the problem is.

#3

Matthias Ballmann

Dec 03, 2018

ok, tj wrote me:

„I have a TODO item on a list to find out what it would take to support Publisher for Ansel 3. I have not yet begun work on Ansel 3 so it’s hard to say when support for Publisher would come.“

so I guess I cannot use grids anymore because we use ansel and publisher in every install. I can’t use fluids either because publisher doesn’t support them. But I completely understand, that you cannot add und support all the field types.

#4

BoldMinded (Brian)

Dec 03, 2018

I know the Fluid field incompatibility with Publisher is an issue, but I’m going to start working on it again after putting it off for too long.

Login to reply

Contact

For add-on support, please use the Support section. General inquries and pre-sale questions can be sent to support@boldminded.com.