Be sure to checkout our newest add-on, Speedy — Advanced Caching for ExpressionEngine.

Compatibility updates:

  • Publisher is EE5 compatible, but it does not currently support the Fluid field (it's in the works).

Ticket: Blocks with same name as EE fields cause rendering issues

Status Resolved
Add-on / Version Bloqs 4.0.3
Severity
EE Version 4.3.1

BoldMinded (Brian)

Jun 04, 2018


Description:
I have a site that I’ve been working on upgrading from EE2 to EE4. I upgraded from Blocks to Bloqs during the upgrade.

The blog channel uses Bloqs to create content. On the single entry template the Bloqs tags output the Bloqs tags as they are in the template with no actual content. Other non-Bloqs fields are rendering on the page without a problem.

I was getting an error for a while on this page that was an uncaught exception that I finally narrowed down to an issue with SEO Lite. But now that the error is gone the Bloqs content is not getting output.

What’s weird is on my local machine I have an earlier working version of the site at EE 4.2.1. On this site the page DOES output Bloqs content.

Detailed steps to reproduce the issue:
1. Update site to latest EE 4.3.1
2. View Template with Bloqs tags

Both environments are using PHP 7.2.5. I was originally using 7.2.5 locally and 7.0.x on the remote box but I updated that to 7.2.5 also just to mask sure that wasn’t an issue.

Unfortunately I can’t provide login info due to an NDA.

Bloqs code in template:
blog_content is the Bloqs field name.

{blog_content}

  {headline}

{heading}

  {/headline}

  {subhead}

{heading}

  {/subhead}

  {copy_block}
    {copy}
  {/copy_block}

  {full_width_image}

     
     

  {/full_width_image}

  {floated_image}
    {image}
  {/floated_image}

  {full_width_video}
    {video_link}
 

{video_caption}

  {/full_width_video}
 
{/blog_content}

 

 

 

#1

BoldMinded (Brian)

Jun 04, 2018

If you can’t provide a login there isn’t much I can do. This is 99.9% an issue with your environment, otherwise I’d be getting numerous similar reports. You said it worked in an earlier version… my suggestion is to compare the current version to the new version for changes. Also make sure all caching is off.

#2

BoldMinded (Brian)

Jun 04, 2018

Double check your template code too, and try to re-create the issue with a new Bloqs field and a new template with nothing else in it, no css, js etc, just an exp:channel:entries tag and the necessary Bloqs code to make the issue occur.

#3

Kevin Kemmerly

Jun 04, 2018

Comment has been marked private.

#4

BoldMinded (Brian)

Jun 04, 2018

Don’t recreate the content, that’s a waste of time. Can you take a screenshot of or export your exp_blocks table so I can see the data?

#5

Kevin Kemmerly

Jun 05, 2018

Comment has been marked private.

#6

BoldMinded (Brian)

Jun 05, 2018

Can you provide CP access and I can take a look myself? Also point me to an entry I’d that has blocks but are not displaying.

#7

Kevin Kemmerly

Jun 05, 2018

Comment has been marked private.

#8

BoldMinded (Brian)

Jun 05, 2018

Yeah this is weird. There have definitely been some template parsing changes since EE2, so maybe there is an internal bug? I’ll keep this on my to-do list… perhaps add some checking to prevent a block from being named the same as an existing EE field. Glad you sorted it out though.

#9

BoldMinded (Brian)

Oct 02, 2018

Resolving this ticket b/c I think its a bug with EE itself, not Bloqs. https://expressionengine.com/support/bugs/23706/bug-in-get_pair_field-method

Login to reply

Contact

For add-on support, please use the Support section. General inquries and pre-sale questions can be sent to support@boldminded.com.