Be sure to checkout our newest add-on, Speedy — Advanced Caching for ExpressionEngine.

Compatibility updates:

  • Publisher is EE5 compatible, but it does not currently support the Fluid field (it's in the works).

Ticket: Relationship data lost when saving channel entry with Publisher Installed, but disabled

Status Resolved
Add-on / Version Publisher 1.6.9
Severity
EE Version 2.8.1

A2 Hosting

Dec 08, 2015

We installed Publisher and when enabled everything works great, but if we

1) disable publisher
2) open channel entry to edit it (relationships show up fine)
3)  save the entry (with or without making changes)
4) go back into edit the entry and all relationships are lost (single relationship, multiple relationship, relationships in grid [the grid rows are left, but the relationship drop-down has no relationship selected])

#1

BoldMinded (Brian)

Dec 08, 2015

Thanks for the report. Why disable Publisher and continue to make updates to the site? While it sounds like a legit bug, it doesn’t sound like a normal use case. Usually when people buy it they install and keep it enabled. The disable option is primarily meant for quick debugging instead of installing only to disable it.

#2

BoldMinded (Brian)

Dec 08, 2015

To be honest this sounds like a bit of an edge case and haven’t had similar reports, and I don’t think this will be an issue with Publisher 2.0 for EE 3, so I may shelve this one until I get another such report. If you really need to disable Publisher for any extended period of time, such as you’re not ready to use its features on the site, then you should just un-install it. The disable is meant for very short term testing/sanity check type stuff.

#3

Matt Atcheson

Dec 21, 2015

We have also just had this issue, where the client changed their mind for now? So not wanting to fulling uninstall it, but if that’s what is required then that is what I will do for now.

#4

BoldMinded (Brian)

Dec 21, 2015

I haven’t tried this, but you’re welcome to give it a go. But if you go into the exp_modules table and delete the Publisher row, and also go into exp_extensions table and set the enabled column for all Publisher_ext rows to “n” that would effectively uninstall the module without removing any of its data. Just backup your db and try this in a local/dev environment first.

I may consider adding this as an option to version 2.0, something more than “disable” but not too much that it dumps the existing data and does a true un-install.

#5

Digital Designs

Jul 05, 2016

We have also had this issue and have confirmed it is a issue with Publisher. We have effectively “uninstalled” the module (with Ellis Labs support) in the method that Brian describes above. We haven’t lost any data, but we are unable to use the module at this point and the client is in need of multi-lingual capabilities asap. We are hoping to be able to activate Publisher again and avoid working with a replacement. Publisher is by far the best multi-lingual solution we have come across for EE.

#6

BoldMinded (Brian)

Jul 05, 2016

If you need multilingual functionality why did you uninstall it? I’m confused as to what you’re trying to achieve.

#7

BoldMinded (Brian)

Jul 05, 2016

I think I see what the issue is and have a fix. Will post a new build shortly.

#8

BoldMinded (Brian)

Jul 05, 2016

Comment has been marked private.

#9

BoldMinded (Brian)

Jul 05, 2016

Posted new build in previous private message that should fix the issue. You will have to re-enable then disable Publisher for it to work. (note not uninstall, just the enable/disable setting option).

#10

Digital Designs

Jul 05, 2016

Thank you, we will give it a try and let you know how it goes.

We disabled it because we needed the relationships to save.

Thanks again!

#11

BoldMinded (Brian)

Oct 02, 2018

Disabling Publisher is no longer an option, so this ticket is irrelevant now.

Login to reply

Contact

For add-on support, please use the Support section. General inquries and pre-sale questions can be sent to support@boldminded.com.