All add-ons currently require PHP 7.4 or greater.

On July 4th 2024 PHP 8.2 will be the new minimum requirement for all add-ons. Expect any add-on released after that date to require 8.2 or greater. Some releases may not immediately take advantage of 8.x specific features in PHP, which means you might, be able to continue using new releases in PHP 7.4, however, if you experience an error the first thing you should do is update to PHP 8.2 then create a support ticket if the error persists.

Publisher does not support the Fluid field type. Please do not contact asking when support will be available.

If you purchased an add-on from expressionengine.com, be sure to visit boldminded.com/claim to add the license to your account here on boldminded.com.

Ticket: System Messages ext issue

Status Resolved
Add-on / Version Custom System Messages
Severity Critical
EE Version 24

Jordan Larrigan

May 15, 2013

Moved over from here - http://expressionengine.stackexchange.com/questions/10342/system-messages-ext-issue/10382?noredirect=1#10382

I am using new relic to watch my EE install and am seeing a ton of slowness around this call.

I am also using http://devot-ee.com/add-ons/custom-system-messages - and am not sure if the issue is coming from that plugin or the EE system messages.

Has anyone seen this before?

System_­messages_­ext­:­:extend_­output_­class

Images located on stack still

#1

BoldMinded (Brian)

Hi Jordan. I see the log, but I’m not sure I understand it fully. The CSM line is in red, but its duration and time is just a fraction higher than several other core EE calls, so I’m not sure why CSM is being singled out.

#2

BoldMinded (Brian)

Actually, its a fraction faster than the core EE calls.

#3

BoldMinded (Brian)

Jordan, I was looking at the wrong part of the graph. In the ext.system_messages.php file find all instances of:

session_start();

and replace it with

//session_start();

And see if that does anything.

#4

Jordan Larrigan

Ok thanks. I will try that and see how it works out. It may take a few days to get useful results. Thanks!

#5

Jordan Larrigan

Actually I have 2 - https://gist.github.com/jlarrigan/b74c14c3dbcc8a9f2ed5

#6

Jordan Larrigan

nvm… I reread your email.. My bad :-p

#7

Brian Litzinger

So this issue is resolved?

#8

BoldMinded (Brian)

Marking this as resolved. If this is still an issue please open a new ticket, thanks!

Login to reply