All add-ons currently require PHP 7.4 or greater.

On July 4th 2024 PHP 8.2 will be the new minimum requirement for all add-ons. Expect any add-on released after that date to require 8.2 or greater. Some releases may not immediately take advantage of 8.x specific features in PHP, which means you might, be able to continue using new releases in PHP 7.4, however, if you experience an error the first thing you should do is update to PHP 8.2 then create a support ticket if the error persists.

Publisher does not support the Fluid field type. Please do not contact asking when support will be available.

If you purchased an add-on from expressionengine.com, be sure to visit boldminded.com/claim to add the license to your account here on boldminded.com.

Ticket: Error returned when trying to install

Status Resolved
Add-on / Version DataGrab 5.0.3
Severity
EE Version 7.3.1

Christian Rochford

Jul 18, 2023

see screenshot attached

#1

BoldMinded (Brian)

Comment has been marked private.

#2

Christian Rochford

Hi Brian, I’m still getting the same error having installed the version you shared, Thanks, Christian

#3

BoldMinded (Brian)

Are you upgrading from a previous version?

#4

BoldMinded (Brian)

Please double check that all the files from the zip are correctly uploaded and no old files exist. I just tested an install in a brand new EE environment and it worked fine. Based on the error message it looks like an old file is attempting to be loaded.

#5

Christian Rochford

Hi Brian, can you let me know which file you’re referring to. I check the filepaths in the system error and they all exist on a fresh install of the latest EE, also I’ve completed removed any old version of datagrab when running the install of the addon Thanks! Christian

#6

BoldMinded (Brian)

It’s the upd.datagrab.php file. The 3rd line should be

use BoldMinded\DataGrab\Dependency\Litzinger\Basee\Updater;

Not

use BoldMinded\DataGrab\Library\Basee\Updater;

Which is what is in your screenshot and is the old path to the file it’s trying to reference.

#7

Christian Rochford

Apologies Brian, the older install was remove since that first screenshot, the error i see now is:

Error Caught Class ‘BoldMinded\DataGrab\Library\Basee\Updater’ not found user/addons/datagrab/upd.datagrab.php:58

Stack Trace: Please include when reporting this error

0 ee/legacy/libraries/addons/Addons_installer.php(71): Datagrab_upd->install()

1 ee/legacy/libraries/addons/Addons_installer.php(327): Addons_installer->install_module(‘datagrab’)

2 ee/legacy/libraries/addons/Addons_installer.php(37): Addons_installer->_update_addon(‘datagrab’, ‘module’, ‘install’, false)

3 ee/ExpressionEngine/Controller/Addons/Addons.php(1437): Addons_installer->install(‘datagrab’, ‘module’, false)

4 ee/ExpressionEngine/Controller/Addons/Addons.php(614): ExpressionEngine\Controller\Addons\Addons->installModule(‘datagrab’)

5 [internal function]: ExpressionEngine\Controller\Addons\Addons->install(Array)

6 ee/ExpressionEngine/Core/Core.php(268): call_user_func_array(Array, Array)

7 ee/ExpressionEngine/Core/Core.php(124): ExpressionEngine\Core\Core->runController(Array)

8 ee/ExpressionEngine/Boot/boot.php(184): ExpressionEngine\Core\Core->run(Object(ExpressionEngine\Core\Request))

9 html/admin-krL4HeYwX6oH.php(144): require_once(‘…’)

9 html/admin-krL4HeYwX6oH.php(144): require_once(‘…’)

#8

BoldMinded (Brian)

Yeah thats still not the correct path, that still looks like an old file is being loaded. Did you completely remove the old datagrab folder from the add-ons directory? You didn’t rename it to datagrab-backup or something?

#9

Christian Rochford

Hi Brian, thanks for your response. This website is hosted on a 3 cluster server, I’ve access all 3 clusters, have deleted the datagrab addon on each and have manually added the latest addon on each, yet I’m still seeing the error. If there’s a filepath and/or function you can reference for me in the error log can you please let me know so I can reach out to the hosts detailing the issue Thanks, Christian

#10

BoldMinded (Brian)

I’m not sure what additional info I can provide. When you open the upd.datagrab.php file what do you see on line 3 (or the first few lines)?

Have you tried this on a local or dev environment first that isn’t a multi-server cluster? Or tried it on a clean EE install?

#11

Christian Rochford

Thanks Brian, the following lines start of the upd.datagrab.php file

use BoldMinded\DataGrab\Dependency\Litzinger\Basee\Setting; use BoldMinded\DataGrab\Dependency\Litzinger\Basee\Updater;

I have tested this in a fresh install and its working well, so I do suspect there’s an issue with the cluster, its jsut not clear to me why the error is referencing removed code, will dig a bit deeper on this

Thanks, Christian

#12

BoldMinded (Brian)

If I had to guess it is a caching issue, or maybe they’re doing an rsync to copy files and something isn’t working correctly. But yeah, definitely sounds like something to talk to your hosting provider about.

Login to reply