Publisher does not support the Fluid field type. Please do not contact asking when support will be available.

If you purchased an add-on from, be sure to visit to add the license to your account here on

Ticket: Upgrading Snaptcha broke a static form on my site.

Status Resolved
Add-on / Version Snaptcha 3.2.2
EE Version 7.2.17

Varen Swaab

Jun 05, 2023

Hi there

I recently upgraded Snaptcha from an older version. I don’t know the previous version number but it was at least a year old.

My site is under development and therefore not easily accessible. But here is a short description of what happens. I did not have this problem until I upgraded Snaptcha and no other changes were made that could affect this functionality.

I have a ‘static’ for on all my pages (in the footer) that simply passes a user input variable to a location search database to return a location value, all handled by javascript. Now, when I use this form, instead of working as it has, it results in a “This form has expired.” notice.

Just for fun, I tried to add the {exp:snaptcha:field} tag to the field and nothing happened either way. I also tried each of the three protection settings in Snaptcha’s CP and nothing changed either. So I’m kind of lost as to what to try next. I’m adding screenshots of the process below and also the extremely simple html of the form causing trouble.

I suppose it’s worth mentioning that I don’t need Snaptcha on this form and that’s not my goal. My goal is to be able to use this form without errors and still have Snaptcha perform well on standard EE forms.

If you’d like site CP access please let me know but I didn’t think it would be necessary right now.

Thanks very much.

Varen Swaab



BoldMinded (Brian)

Jun 05, 2023

Did you try uninstalling and reinstalling Snaptcha?


Varen Swaab

Jun 12, 2023


I did a lot of troubleshooting and discovered that I had recently added the tag


to the footer of my pages. It never occurred to me that I needed to add a Snaptcha tag to this form, once I did everything started working again. You might want to make a note in the documentation that the Snaptcha tag needs to be in that form.




BoldMinded (Brian)

Jun 12, 2023

Thanks, I’ll do that. Glad it’s working for you now.

Login to reply