All add-ons currently require PHP 7.4 or greater.

On July 4th 2024 PHP 8.2 will be the new minimum requirement for all add-ons. Expect any add-on released after that date to require 8.2 or greater. Some releases may not immediately take advantage of 8.x specific features in PHP, which means you might, be able to continue using new releases in PHP 7.4, however, if you experience an error the first thing you should do is update to PHP 8.2 then create a support ticket if the error persists.

Publisher does not support the Fluid field type. Please do not contact asking when support will be available.

If you purchased an add-on from expressionengine.com, be sure to visit boldminded.com/claim to add the license to your account here on boldminded.com.

Ticket: Directory access is forbidden.

Status Resolved
Add-on / Version DataGrab 4.2.2
Severity
EE Version 7.2.15

Stephane Boudreau

Apr 21, 2023

local MAMP install, PHP 7.4.33

This message is displayed in the Status column of the DataGrab plugin Use a saved import section.
“Directory access is forbidden.”

My 6th import keeps displaying the error “Directory access is forbidden.” when I try and run the import. I don’t know what *directory* this message is referring to, the path to the 6th .csv file is the same as the others. I’ve tried using moving the 6th .csv file in the root directory and other directories, but I get the same message. I have successfully created 5 imports that use .csv files (3 columns, comma separated).

The .csv files are all created using Numbers.app - and they pass as valid on Validators
I have created new channels, new DataGrab imports - all give me the same message.
I have tried renaming previous .csv files that were successful previously - all give the same message.

if I use the “Import URL” - I get the same message “Directory access is forbidden.” No other message or information.

There are currently no “No Developer logs found.” in my Tools->Logs section of EE

I was curious if you could steer me towards the meaning/cause of the error?

Thank you in advance,

#1

BoldMinded (Brian)

Hi, Stephane. This doesn’t sound like a DataGrab specific issue, this sounds more like an issue with EE itself as that is a common message used in EE files when it’s trying to read from a directory that can’t be read from. DataGrab’s codebase does not contain such an error message. For example, if you search your codebase for “Directory access is forbidden” you’ll probably see a lot of index.html files with that error… it means that whatever is requesting a file from within that directory it isn’t finding that file and is likely defaulting to the index.html file.

#2

Stephane Boudreau

Ok, thanks Brian. The plugin is worked great on my other ‘similarly’ configured local/dev site. I’ll try out a fresh install of EE and see what happens.

Thanks

Login to reply