All add-ons currently require PHP 7.4 or greater.

On July 4th 2024 PHP 8.2 will be the new minimum requirement for all add-ons. Expect any add-on released after that date to require 8.2 or greater. Some releases may not immediately take advantage of 8.x specific features in PHP, which means you might, be able to continue using new releases in PHP 7.4, however, if you experience an error the first thing you should do is update to PHP 8.2 then create a support ticket if the error persists.

Publisher does not support the Fluid field type. Please do not contact asking when support will be available.

If you purchased an add-on from expressionengine.com, be sure to visit boldminded.com/claim to add the license to your account here on boldminded.com.

Ticket: After Expression Engine upgrade Datagrab is no longer importing

Status Resolved
Add-on / Version DataGrab 4.2.1
Severity
EE Version 7.2.10

Cecil J Bridgewater

Feb 25, 2023

Data Grab stopped importing my jokes of the week. The progress bar does not move, and nothing happens. I have attached a screenshot of the log

It worked fine until about a month ago before the latest updates to ExpressionEngine.  I only run it manually every few weeks to pull in the latest jokes.

I attempted to pull a different RSS(XML) Feed with the same results. I have attempted a reinstall of Datagrab. I also attempted the same fix you indicated in another Stop importing ticket but Datagrab throws errors when I made that change so I reloaded the original PHP file

PHP version is 8.0.28

#1

BoldMinded (Brian)

What are the new errors you’re referring to after you made that change?

#2

Cecil J Bridgewater

You can close this. It was my error. I was getting can’t close brackets errors. When I copied the code that was in the other ticket. I included the top “{”. This code fragment may be needed in future updates.

Thank you. The system is working again.

#3

BoldMinded (Brian)

Good to hear!

Login to reply