All add-ons currently require PHP 7.4 or greater.

On July 4th 2024 PHP 8.2 will be the new minimum requirement for all add-ons. Expect any add-on released after that date to require 8.2 or greater. Some releases may not immediately take advantage of 8.x specific features in PHP, which means you might, be able to continue using new releases in PHP 7.4, however, if you experience an error the first thing you should do is update to PHP 8.2 then create a support ticket if the error persists.

Publisher does not support the Fluid field type. Please do not contact asking when support will be available.

If you purchased an add-on from expressionengine.com, be sure to visit boldminded.com/claim to add the license to your account here on boldminded.com.

Ticket: Deprecation warning when running with php 8.1 (another one)

Status Resolved
Add-on / Version Publisher 3.9.1
Severity
EE Version 6.4.5

Gavin @ JCOGS

Feb 13, 2023
Deprecated
Return type of BoldMinded\Publisher\Dependency\MyCLabs\Enum\Enum::jsonSerialize() should either be compatible with JsonSerializable::jsonSerialize(): mixed, or the #[\ReturnTypeWillChange] attribute should be used to temporarily suppress the notice

user/addons/publisher/vendor-build/myclabs/php-enum/src/Enum.php, line 222

    Severity: E_DEPRECATED

php 8.1.15

#1

BoldMinded (Brian)

Comment has been marked private.

#2

Gavin @ JCOGS

That’s fixed it! Thanks!

Login to reply