Publisher is EE6 compatible, but it does not support the Fluid field. Please do not contact asking when support will be available.

If you purchased an add-on from expressionengine.com, be sure to visit boldminded.com/claim to add the license to your account here on boldminded.com.

Ticket: Error with ‘Color Picker’ fields when saving entry Revisions

Status Resolved
Add-on / Version Bloqs 5.0.3
Severity
EE Version 6.3.5

Full Circle Developers

Sep 08, 2022

When logged into the CMS and editing a channel entry that contains a Bloqs field, we have a bloq containing a text input and a Color Picker option (which is required). This bloq also is a component, but there are no errors coming from the associated Component bloqs.

When navigating back to a saved Revision for the entry that contains that bloq with a Color Picker field, we are unable to save the entry to a previous revision because of it being required, yet it cannot be edited. It’s as if it’s not pulling the revision’s Color Picker value into the revision to be saved, and I cannot modify the Color Picker value (it shows an odd text input that’s un-clickable/unmodifiable).

#1

BoldMinded (Brian)

Sep 08, 2022

Can you please create a video illustrating the issue?

#2

Full Circle Developers

Sep 12, 2022

Hi Brian,

I shared a video via WeTransfer on Friday, so please let me know if that came through to you or not.

#3

BoldMinded (Brian)

Sep 12, 2022

Yep, I got it. Thanks. It’s going to be a few days until I can look into this. I was on vacation last week and I’m going to be swamped this week.

#4

BoldMinded (Brian)

Sep 12, 2022

I haven’t been able to test this, but when I do the first think I will do is test the Color Picker field outside of Bloqs as a standalone field and see if it exhibits the same behavior when editing a revision. Have you tried this? I’d like to isolate if this is a Bloqs specific issue or if there is a chance it’s a broader issue with the fieldtype in EE.

#5

Full Circle Developers

Sep 12, 2022

I did test this as a Color Picker field not contained within a Bloq, and it seems that the revisions are able to be saved. It works as intended whether or not the field was required or not, whereas the Color Picker within a Bloq was showing an error with the Color Picker field (being required or not).

#6

BoldMinded (Brian)

Sep 12, 2022

Excellent, thanks. That’ll save me some time when I can get around to investigating it.

#7

BoldMinded (Brian)

Sep 13, 2022

Comment has been marked private.

#8

Full Circle Developers

Sep 14, 2022

That seems to have done the trick. Thanks again, Brian.

#9

BoldMinded (Brian)

Sep 14, 2022

Good to hear!

Login to reply