All add-ons currently require PHP 7.4 or greater.

On July 4th 2024 PHP 8.2 will be the new minimum requirement for all add-ons. Expect any add-on released after that date to require 8.2 or greater. Some releases may not immediately take advantage of 8.x specific features in PHP, which means you might, be able to continue using new releases in PHP 7.4, however, if you experience an error the first thing you should do is update to PHP 8.2 then create a support ticket if the error persists.

Publisher does not support the Fluid field type. Please do not contact asking when support will be available.

If you purchased an add-on from expressionengine.com, be sure to visit boldminded.com/claim to add the license to your account here on boldminded.com.

Ticket: Search and Asset Add-on Synchronization Issue

Status Resolved
Add-on / Version Publisher 3.5.1
Severity
EE Version 6.2.6

Mephics (T) Ltd

Mar 19, 2022

Site updated from ee2.9.3 t0 ee6.2.6

1. I am having an issue were by i have change a default language and it seems files and photos on assets fields are not appearing on either front or back end, however they appear in the assets field of previous default language. Is there a way to synchronize them so that they appear on both?, website updated to Publisher 3.5.1 and Assets 3.4.5

2. I am getting error on simple search on both languages, see attached

 

#1

BoldMinded (Brian)

Hi there. Can you copy and paste the query error that starts with SQLSTATE so it includes the entire query string so I can run it on a database? I can’t copy and paste it from the image.

#2

BoldMinded (Brian)

Regarding issue #1, it is impossible or me to predict what has happened based on what you described. Honestly this sounds like a very difficult thing to debug without full access to the site, and even then I need you to create a base minimum template of just a channel:entries tag and an Assets field so I can see the issue happen on the front-end, and point me exactly to what entry in the control panel I can see the issue happening. I’m not even sure I can guarantee I can figure out what is going, but I can give it a look, if you provide CP access (to a dev site, not production), and possibly need FTP access so I can debug the code. You can edit the ticket and provide the access credentials in the provided fields.

#3

BoldMinded (Brian)

The page you sent me in the email is not a bare bones example to replicate the issue. Please create a new blank template with a single entries tag in it, nothing else. No header, footer, styles etc. Also tell me what the entry id is that is displaying in that template.

Remember, I’m not as familiar with your site as you are, so I need no additional noise and clear direction so I can get in, debug, and get back out of the site without making guesses as to where things are or how they work.

#4

Mephics (T) Ltd

Comment has been marked private.

#5

BoldMinded (Brian)

I also need more information on how to replicate the sql error issue. What are you searching for to cause the error?

#6

BoldMinded (Brian)

So the problem with the Assets field is that there is no translated content, at least for entry #942. I suspect this is the issue for the other entries as well. You have the content fallback options turned on, so I think it should still be showing the Asset field value from English even when viewing the Swahili version. I’ll have to look into this a little more, so it’ll be a few days before I can get to it. Run the following query on your database and you’ll see what I’m referring to.

select * from exp_publisher_titles where entry_id = 942
#7

BoldMinded (Brian)

Ok, so the issue is that Swahili is set to your default language, and if you run the query above with entry 942 or 752 (2 entries I was testing) you’ll see that there is no data for those entries in Swahili (which is language ID 2). If you set English as you default language then the Assets field will correctly display the English content, b/c its the default language and it is doing a content fallback lookup. So what you originally reported for issue #1 is a data issue, not a bug. You’ll need to change English to your default language, or save content so a Swahili version exists. This isn’t something I can fix.

I’m still looking into issue #2.

#8

BoldMinded (Brian)

The search query should be fixed now. I made the fix to the Publisher_search.php file on your server. I can send you a new zip file if you need it, or if the fixed file on the server is all you need, you should be good to go.

#9

Mephics (T) Ltd

The search is working fine now, thanks!, the second issue on the asset fields as you have noted is if there is no translations then at least it could have shown entry language files / the same files we are seen on the other language…

#10

Mephics (T) Ltd

I was thinking is there a way we can just use “category” and “phrases” translations only and ignore the “custom fields” translations? since in our case there are not being used much in this particular site!… most information are posted either in English Language with Id1 or Swahili Language Id2 and not both! maybe this will help our issue of assets field not showing on default language id2 on old posts

#11

BoldMinded (Brian)

I wouldn’t use category or phrase translations for content like that. I would recommend revisiting your content strategy, and maybe spending some time to just re-save those entries in both languages to make sure the data exists. Or make English your default language, in which case it solves all your problems, but I don’t know if this site is intended to be in Swahili first, and English second, or English first and Swahili second.

#12

Mephics (T) Ltd

The default language is suppose to be Swahili - Id2, however even making default language English - Id1, still i have the same issue were by in old data which is a lot it does not show in Swahili - id2 in the asset field (attachments and photos)

#13

BoldMinded (Brian)

The test page you linked to earlier is working as expected. Entry #752 does not have a Swahili translation, and since it is the default language, it can’t show the English content as its fallback data. This is a data issue, I don’t see any indications of a bug here.

Login to reply