All add-ons currently require PHP 7.4 or greater.

On July 4th 2024 PHP 8.2 will be the new minimum requirement for all add-ons. Expect any add-on released after that date to require 8.2 or greater. Some releases may not immediately take advantage of 8.x specific features in PHP, which means you might, be able to continue using new releases in PHP 7.4, however, if you experience an error the first thing you should do is update to PHP 8.2 then create a support ticket if the error persists.

Publisher does not support the Fluid field type. Please do not contact asking when support will be available.

If you purchased an add-on from expressionengine.com, be sure to visit boldminded.com/claim to add the license to your account here on boldminded.com.

Ticket: Developer Log Error: Using Deprecated tag pairs in a Bloqs field

Status Resolved
Add-on / Version Bloqs 4.9.1
Severity
EE Version 5.4.3

Nikolina Cubra

Feb 22, 2022

Hi!

I’m getting the below error in my Developers Log and I don’t see how is that field Deprecated, all the Bloq fields I’ve created haven’t been deprecated in the Bloqs settings.

‘‘It looks like you’re using the deprecated {close:[block_name]}{/close:[block_name]} tag pairs in a Bloqs field. It is recommended to switch to the {bloqs:children} tag. The {close:[block_name]}{/close:[block_name]} tag pair logic will be removed in a future version of Bloqs’‘

Here is a piece of our Template where the tag in question is being used:

{testimonials_slideshow_row}

Testimonials

data-cycle-fx="scrollHorz"
data-cycle-timeout="6000"
data-cycle-speed="900"
data-cycle-slides=">

article”
data-cycle-auto-height=“calc”
data-cycle-next=”.news-next”
data-cycle-prev=”.news-prev” >
{close:testimonials_slideshow_row}

{/close:testimonials_slideshow_row}
{/testimonials_slideshow_row}

{testimonial_text}

{content}

{/testimonial_text}

Thanks in avdance for your help.

#1

BoldMinded (Brian)

Please update to the latest version… you’re several releases behind.

#2

BoldMinded (Brian)

It’s not saying the field is deprecated, it’s saying the template code you’re using to render children is deprecated, and it’s suggesting that you switch it to the new syntax.

https://docs.boldminded.com/bloqs/docs/features/nesting#template-tags

#3

Nikolina Cubra

Hi Brian!

I updated Bloqs and my EE to v6, I also changed all my templates tags to not include the deprecated {close:[block_name]}{/close:[block_name]} I’ve now put {bloqs:children} tag in their place (relating to this ticket).

However the Bloqs I created don’t seem to be loading on the publish page any longer, they just have a ”Loading” banner on there that just never loads and I am unable to click on any other bloqs or edit anything, if I try clicking on anything it immediately jumps me to the top of the page and nothing happens. I tried in Chrome, Safari and Mozzila and I’ve cleared all Cache in EE and still nothing.

I am not quite sure why this is occurring as everything worked fine before I updated to EE6 nothing was changed or updated (not Templates not our PHP) so when I updated I thought maybe it is because I am still using the deprecated block in my templates, however after updating that it still isn’t working (apologies I don’t see a button to attacha na image or video)

Many thanks Nikolina

#4

BoldMinded (Brian)

Hi again Nikolina. This sounds like a separate issue, and you’ll need to share screenshots or a video b/c I’m not exactly sure what you’re referring to. It kind of sounds like a JavaScript error… did you check your browser’s console for errors? Are there any 404s for missing .js files in the Network log?

Login to reply