All add-ons currently require PHP 7.4 or greater.

On July 4th 2024 PHP 8.2 will be the new minimum requirement for all add-ons. Expect any add-on released after that date to require 8.2 or greater. Some releases may not immediately take advantage of 8.x specific features in PHP, which means you might, be able to continue using new releases in PHP 7.4, however, if you experience an error the first thing you should do is update to PHP 8.2 then create a support ticket if the error persists.

Publisher does not support the Fluid field type. Please do not contact asking when support will be available.

If you purchased an add-on from expressionengine.com, be sure to visit boldminded.com/claim to add the license to your account here on boldminded.com.

Ticket: always seeing the “add your first” message

Status Resolved
Add-on / Version Bloqs 4.11.0
Severity
EE Version 6.2.4

Tim Murtaugh

Jan 28, 2022

I just updated a site to the latest EE and Blogs. On all existing entries with blogs content, I’m seeing the “no bloqs found, add your first!” messaging.

 

#1

BoldMinded (Brian)

Tim, can you please provide screenshots or something? Did you check your JS console for any errors?

#2

Tim Murtaugh

Added a screenshot. There’s nothing in the console.

#3

BoldMinded (Brian)

This happens on new entries? Existing entries? Was this an upgrade from a previous version of Bloqs or fresh install? Can you capture a video of this happening? Include the initial page load so I can see what is happening.

#4

Tim Murtaugh

It’s an update from EE 5.4.3 and Blogs 4.2.3, and I just discovered it’s related to publish layouts.

My Bloqs fields aren’t in the first tab, so in order to get a video of the field loading in, I needed to move the tab it’s in to the first position. When I moved the tab to the first position in the Publish Layout, the message doesn’t appear.

It reappears when I move the tab with the Bloqs field back to its original position.

#5

BoldMinded (Brian)

I’m definitely going to need to see a video. I just tested in Safari and Chrome, moved 3 Bloqs fields to different tabs, moved the tabs around etc. In no circumstance was I able to replicate the issue you described.

#6

Tim Murtaugh

video attached

#7

Tim Murtaugh

This is in Safari, BTW.

#8

Tim Murtaugh

Oh wait, the file is too big…

#9

Tim Murtaugh

https://www.icloud.com/iclouddrive/054PIGyEW_AVjL_fYvHIBkqPQ#Screen_Recording_2022-01-28_at_2.35.22_PM

#10

BoldMinded (Brian)

There has to be some JS or CSS conflicting somewhere. Have you tried creating a new channel, with no other custom fields in it except for Bloqs and see if the issue still occurs?

Or better yet, backup your database and uninstall all other 3rd party add-ons except for Bloqs.

#11

BoldMinded (Brian)

Tim, did you get a chance to try to see if there was a conflict with another add-on?

#12

BoldMinded (Brian)

Tim, it’s been a month with no reply, so I’m assuming the issue resolved itself or you found a conflict and resolved it? I still haven’t been able to replicate this or have had any similar reports, so I’m assuming it was an issue specific to your environment. I’m going to close this ticket out. If you can provide more information that I can use to investigate the issue feel free to re-open the ticket.

#13

Tim Murtaugh

I’m sorry for dropping the ball on this — the error is on a staging site that I’m prepping to update EE on a production site, but the update hasn’t been a priority.

I just uninstalled all addons except Bloqs, and the issue still exists. I also made sure both EE and Bloqs are updated to the latest versions.

I made a channel with no other fields except for a single Bloqs field with a single field option in it. If the Bloqs field is in the first tab, the “no bloqs found” element doesn’t show. As soon as I move the field to a new tab, it appears.

#14

BoldMinded (Brian)

Have you tried re-creating this in a brand new EE environment? What you reported seems odd because no one else has reported similar issues and I’ve tried to replicate it in 2 different sites, and can’t. There is a newer version of Bloqs available too. Make sure you’ve updated to it and see if it still happens. If you can replicate it in a brand spanking new EE site and with the latest version of Bloqs I’ll take another look at it, but as of right now I have nothing to go on b/c I can’t replicate it.

#15

BoldMinded (Brian)

Tim, I’m going to close this out. If you can re-create it in a brand spankin new EE environment with no other add-ons or any modifications re-open this ticket and I’ll take another look, but I just haven’t been able to replicate it nor have I had similar reports.

Login to reply