All add-ons currently require PHP 7.4 or greater.

On July 4th 2024 PHP 8.2 will be the new minimum requirement for all add-ons. Expect any add-on released after that date to require 8.2 or greater. Some releases may not immediately take advantage of 8.x specific features in PHP, which means you might, be able to continue using new releases in PHP 7.4, however, if you experience an error the first thing you should do is update to PHP 8.2 then create a support ticket if the error persists.

Publisher does not support the Fluid field type. Please do not contact asking when support will be available.

If you purchased an add-on from expressionengine.com, be sure to visit boldminded.com/claim to add the license to your account here on boldminded.com.

Ticket: Turning on Nestable? is breaking the ability to open blocks on the entry page

Status Resolved
Add-on / Version Bloqs 4.11.0
Severity
EE Version 6.2.3

John Derrick

Jan 21, 2022

Hi,

I have turned on Nesting within my Bloqs recently, as I wanted to start working with that feature, but I’m running into an issue. When I enabled Nesting within the field type settings (by toggling Nestable?), and then go back to an entry that should now enable nesting, I cannot open any of my existing blocks - they won’t toggle open. I also can’t use the Expand All function. I can still drag and drop without any issues.

Turning off the Nesting toggle in the field type settings fixes the issue and I can open/edit by bloqs again.

I am seeing the following errors (attached) in Dev Console when the setting is enabled and I try and edit my existing entry, but I’m not sure what to try next. Upgraded to the most recent of EE6 and Bloqs in a dev environment.

Any ideas what might cause this? I ran into the issue in different browsers as well.

Thanks,
John

#1

BoldMinded (Brian)

Based on the error there is an issue with the nesting validation. Try removing blocks from the entry until it works, then share a screenshot of the block settings for the block that was last removed before it started working.

#2

John Derrick

That might be challenging. This is happening on all former entries as far as we can tell, hundreds of them. This site was upgraded from EE2 in November last year, and everything works fine until I turn on the Nesting.

#3

John Derrick

The delete button also doesn’t work, just takes me to top of screen. New entry works fine. Just seems to be our existing entries that have the problem. But we literally can’t edit them at all currently.

#4

John Derrick

I found older entries with a single entry, and some with a dozen or more bloqs; doesn’t seem to matter how many of what type. Can’t delete, put a bloq in draft, or open it to edit, but can move around and reorder.

#5

BoldMinded (Brian)

What is the Bloqs upgrade history on this site? You upgraded from EE 2 last year and upgraded Bloqs? And none of the Bloqs settings have been changed since?

Have you tried re-saving each bloq?

#6

John Derrick

Upgraded to 4.7 of Bloqs during EE6 upgrade. We’ve adjusted bloqs since then, but I just tried saving one of each unique bloq and that appears to have fixed the entry with those bloqs. So I’ll run through each bloq and save it to see if that fixes rhe other entries. Thanks!

Login to reply